[A/V] Player cannot working after call

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Video
--
major
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: leo.bugzilla.gecko, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
STR
1. Start youtube streaming in browser app.
2. Receive call.
3. Reject call.

Then Player can do nothing.
Pause/resume button and seek bar doesn't work at all.

It's find in the case of local play.
The player remain pause state after rejecting call.
And it can be successfully resumed.
(Reporter)

Updated

4 years ago
blocking-b2g: --- → leo?
Hi Leo, 

Which version do you use???

I had tested with the gaia master, it works perfectly. It just paused, and automatic restart after rejecting call.
Flags: needinfo?(leo.bugzilla.gecko)

Comment 2

4 years ago
Hi John,

I have tested this issue with Gaia master of following version:
git commit ID: b9a009103bd70ec77eb8ec9472a943e38d8219b1
build ID: 20130625070052
platform version: 18.1

But issue is still reproducible.
Flags: needinfo?(leo.bugzilla.gecko)
Sorry, one more request:

Would you mind to try the following STR to reproduce the same bug:

1. play video from youtube
2. press power button, device goes sleep
3. press power button, device goes back
4. unlock the device.

You don't need to make the phone call anymore.

BTW, we had done some tests on leo and other devices. It only occurred at leo device.
Keywords: qawanted
Flags: needinfo?(leo.bugzilla.gecko)
Keywords: qawanted

Comment 4

4 years ago
I have tried the steps that you have suggested and here are my findings:
When I lock and unlock phone while youtube video is playing. video player will exit from full screen. This is a different issue.
Flags: needinfo?(leo.bugzilla.gecko)
(Reporter)

Comment 5

4 years ago
Hi John,

May I know what kind of other devices you check?
Is it same version with Leo, 1.1?
Flags: needinfo?(johu)
I had checked with unagi and Inari. They all with the same gaia version. The different part is they are stopping video playing while a call is coming or screen is going off. And they restart playing from the start while call is canceled or screen is on.

If video player exit full screen mode and goes back to youtube list, it is the correct behavior. That is because youtube player is an inline activity, it goes when you go to another app or screen is going off.
Flags: needinfo?(johu)
BTW, we had noticed that some implementation of your image may not equal to ours through this Leo Taipei WW. So, we will continue to check if this kind of issue happens on our image.
(Reporter)

Comment 8

4 years ago
(In reply to John Hu [:johnhu] from comment #6)
> I had checked with unagi and Inari. They all with the same gaia version. The
> different part is they are stopping video playing while a call is coming or
> screen is going off. And they restart playing from the start while call is
> canceled or screen is on.
> 
> If video player exit full screen mode and goes back to youtube list, it is
> the correct behavior. That is because youtube player is an inline activity,
> it goes when you go to another app or screen is going off.

This comment means the right scenario is youtube player should be removed when the call is going up. Is it right?

If so..when there's some problem in current version, do you change video app to be removed?
Yes, it will be removed at system app.

The current behavior is to stop video playing with system app, and resume while it goes back.
(Reporter)

Comment 10

4 years ago
If so, when the video player resume, does it start playback from the 0 seconds?

And one more thing..
Does this patch affect here?? (Patch from Bug 881584)
https://github.com/alivedise/gaia/commit/854b0a35e54753ea9146fb8955510029822904e9
At original version, it starts playback from 0 sec. And currently, yes that patch will affect here. That just landed. So, you may not have that patch in this version. You will have it very soon. So, this bug will not existed. It will be won't fix
This bug is no need to fix because bug 881584 is already landed and it close video app of youtube while it is hidden.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX

Updated

4 years ago
blocking-b2g: leo? → ---
You need to log in before you can comment on or make changes to this bug.