Reload button inconsistencies with frames

VERIFIED DUPLICATE of bug 79063

Status

()

Core
Document Navigation
VERIFIED DUPLICATE of bug 79063
17 years ago
10 years ago

People

(Reporter: Ulrich Grassberger, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.2) Gecko/20010628
BuildID:    

Sometimes 'reload' only reloads frame contents, and sometimes it reloads the
adress in the adress line. If I change the document of a frame subset by
javascript (the actual case was parent.xxx.history.back()) Mozilla will reload
the adress line on a reload.


Reproducible: Always
Steps to Reproduce:
s

Another problem, correlated with this or at least with my code, is that in
frames the back and forth buttons do not work as expected. It´s about using two
frames which both change on every step. I don´t know if it´s just a lucky
circumstance that my code works with IE5 (IE4 doesn´t, Opera5 doesn´t, Ns4
doesn´t), but the code looks rather innocent (though complicated) to me, see
grassomusic.de/english/acpi.htm I guess that it´s a problem of synchronisation,
frames traditionally suffer from that, don´t they?

Comment 1

17 years ago
The problems reported here seems to be bug 79063 for the first one, and bug
85549 for the second one.

*** This bug has been marked as a duplicate of 79063 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
mass-verifying Duplicate bugs which haven't changed since 2001.12.31.

set your search string in mail to "CitizenGKar" to filter out these messages.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.