Last Comment Bug 887524 - Move IDBRequest to WebIDL
: Move IDBRequest to WebIDL
Status: RESOLVED FIXED
: addon-compat, dev-doc-complete, site-compat
Product: Core
Classification: Components
Component: DOM: IndexedDB (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla25
Assigned To: Andrea Marchesini (:baku)
:
Mentors:
: 888599 (view as bug list)
Depends on: 1142210
Blocks: ParisBindings 888591 idbwebidl
  Show dependency treegraph
 
Reported: 2013-06-26 15:16 PDT by :Ehsan Akhgari (out sick)
Modified: 2015-03-20 10:17 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
request.patch (40.14 KB, patch)
2013-07-31 02:51 PDT, Andrea Marchesini (:baku)
no flags Details | Diff | Review
request.patch (40.53 KB, patch)
2013-07-31 08:55 PDT, Andrea Marchesini (:baku)
jvarga: review+
Details | Diff | Review

Description :Ehsan Akhgari (out sick) 2013-06-26 15:16:53 PDT

    
Comment 1 Andrea Marchesini (:baku) 2013-07-31 02:51:32 PDT
Created attachment 783691 [details] [diff] [review]
request.patch
Comment 2 Jan Varga [:janv] 2013-07-31 08:27:41 PDT
Comment on attachment 783691 [details] [diff] [review]
request.patch

Review of attachment 783691 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/indexedDB/IDBRequest.cpp
@@ +24,5 @@
>  #include "IDBEvents.h"
>  #include "IDBFactory.h"
>  #include "IDBTransaction.h"
>  
> +#include "mozilla/dom/IDBOpenDBRequestBinding.h"

Nit: this should go before |#include "nsComponentManagerUtils.h"|

::: dom/indexedDB/IDBRequest.h
@@ +6,5 @@
>  
>  #ifndef mozilla_dom_indexeddb_idbrequest_h__
>  #define mozilla_dom_indexeddb_idbrequest_h__
>  
> +

Nit: remove this empty line

@@ +19,1 @@
>  #include "mozilla/dom/DOMError.h"

#include "mozilla/dom/indexedDB/IndexedDatabase.h"

#include "mozilla/Attributes.h"
#include "mozilla/dom/DOMError.h"
#include "mozilla/dom/IDBRequestBinding.h"
#include "mozilla/ErrorResult.h"
#include "nsCycleCollectionParticipant.h"
#include "nsWrapperCache.h"

#include "mozilla/dom/indexedDB/IDBWrapperCache.h"

@@ +116,5 @@
> +  GetResult(JSContext* aCx, ErrorResult& aRv) const;
> +
> +  nsISupports*
> +  GetSource() const
> +  {

add the main thread assertion, here and below

::: dom/indexedDB/ipc/IndexedDBParent.cpp
@@ +383,5 @@
>  
>    AutoSafeJSContext cx;
>  
> +  ErrorResult error;
> +  JS::Value result = mOpenRequest->GetResult(cx, error);

Is this safe ?

I would expect something like:
JS::Rooted<JS::Value> result ...
Comment 3 Andrea Marchesini (:baku) 2013-07-31 08:55:23 PDT
Created attachment 783798 [details] [diff] [review]
request.patch
Comment 4 Jan Varga [:janv] 2013-07-31 09:59:23 PDT
Comment on attachment 783798 [details] [diff] [review]
request.patch

r=me
Comment 5 Andrea Marchesini (:baku) 2013-07-31 11:07:10 PDT
*** Bug 888599 has been marked as a duplicate of this bug. ***
Comment 6 Andrea Marchesini (:baku) 2013-07-31 15:30:20 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/023d2f835ca0
Comment 7 Andrea Marchesini (:baku) 2013-07-31 15:32:20 PDT
IDBRequest.LOADING and IDBRequest.DONE are gone. Documentation must be updated.
Comment 8 Ryan VanderMeulen [:RyanVM] 2013-08-01 13:58:19 PDT
https://hg.mozilla.org/mozilla-central/rev/023d2f835ca0

Note You need to log in before you can comment on or make changes to this bug.