accessibility doesn't build with optimization

VERIFIED DUPLICATE of bug 88509

Status

()

Core
XUL
--
major
VERIFIED DUPLICATE of bug 88509
17 years ago
17 years ago

People

(Reporter: Chris Abbey, Assigned: John Gaunt (redfive))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
c++ -o nsHTMLSelectAccessible.o -c -DOSTYPE=\"Linux2.4\" -DOSARCH=\"Linux\" 
-DOJI   -I../../dist/include -I../../dist/include 
-I/usr/src/moz/mozilla/dist/include/nspr      -I/usr/X11R6/include   -fPIC  
-I/usr/X11R6/include -fno-rtti -fno-exceptions -Wall -Wconversion 
-Wpointer-arith -Wbad-function-cast -Wcast-align -Woverloaded-virtual -Wsynth 
-pedantic -Wno-long-long -pipe -fshort-wchar -pthread -O3  -DNDEBUG -DTRIMMED 
-I/usr/X11R6/include -DMOZILLA_CLIENT -include ../../config-defs.h 
-Wp,-MD,.deps/nsHTMLSelectAccessible.pp nsHTMLSelectAccessible.cpp
nsHTMLSelectAccessible.cpp: In method `void
nsHTMLSelectWindowAccessible::GetBounds (nsRect &, nsIFrame **)':
nsHTMLSelectAccessible.cpp:652: `listControlFrame' is not a member of
type `nsLayoutAtoms'

machine is x86 RHL 7.1 with kernel and other updates, c++ version (gcc version 
actually) is 2.96, specifically:

Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.1 2.96-85)

this compiled just fine before your 29 June branch landing.


.mozconfig that yielded this is:

mk_add_options MOZ_MAKE_FLAGS=-j2                                              

ac_add_options --disable-tests
ac_add_options --disable-bidi
ac_add_options --enable-optimize=-O3
ac_add_options --disable-debug
ac_add_options --enable-strip-libs
ac_add_options --enable-crypto

The component here was suggested on IRC, please adjust if it's wrong. 
Preemprively assigning to the committer, and copying the sr=r=... feel free to 
remove yourselves if you're not interested.
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 1

17 years ago
Marking as a dupe of bug 88509

the problem is actually with the --disable-bidi 

*** This bug has been marked as a duplicate of 88509 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.