[OTA] [Data Migration] [Calendar] Calendar blank screen after update from v1.0.1 to v1.1.0

VERIFIED FIXED in Firefox OS v1.1hd

Status

Firefox OS
Gaia::Calendar
P1
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: askeing, Assigned: Ganesh Ghosh)

Tracking

(Blocks: 1 bug, {dataloss})

unspecified
1.1 QE4 (15jul)
All
Gonk (Firefox OS)
dataloss
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 verified, b2g-v1.1hd fixed)

Details

(Whiteboard: [migration][LeoVB+])

Attachments

(3 attachments, 3 obsolete attachments)

(Reporter)

Description

5 years ago
### ENV:
Inari
from v1.0.1 (pvt)
    Gaia:     93241eb6c5d6c110710fad8da3ccd4423312b0c9
    Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/9c62297d11b0
    BuildID   20130624070215
    Version   18.0
to v1-train (complete gaia/gecko OTA update)
    Gaia mozillaorg - 16b872bd7d3aa4f1a7ae73bb19806af8b5d23dc0
    Gecko mozillaorg - 914243b75089d42b0672c8b01b7adf33568309f5

Unagi
from v1.0.1 pvt
    Gaia:     93241eb6c5d6c110710fad8da3ccd4423312b0c9
    Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/9c62297d11b0
    BuildID   20130626070217
    Version   18.0
to v1-train
    Gaia mozillaorg - 4d6cbe49fdba32f72ec8bc6280e4782c250ab41e
    Gecko mozillaorg - 914243b75089d42b0672c8b01b7adf33568309f5

PS:
The command of building complete gaia/gecko OTA update package:
B2G_UPDATER=1 B2G_SYSTEM_APPS=1 MOZ_BUILD_DATE=XXX ANDROIDFS_DIR=XXX ./build.sh gecko-update-full
ref: https://wiki.mozilla.org/B2G/Updating

### STR:
1. Flash device to v1.0.1 build from pvt.
2. Change update URL.
3. Connect to Wifi.
4. Open Calendar app.
5. Add events.
6. Install gaia/gecko complete update.
7. After auto-restart, open Calendar app.
8. Check the events in Calendar app.

## Actual results:
Blank screen when launch App after update.

## Expected results:
Calendar can launch and still have original events.
(Reporter)

Updated

5 years ago
Blocks: 885114

Updated

5 years ago
blocking-b2g: --- → leo?
Component: General → Gaia::Calendar

Updated

5 years ago
Keywords: dataloss

Updated

5 years ago
Whiteboard: [migration]

Updated

5 years ago
blocking-b2g: leo? → leo+
Priority: -- → P1
Target Milestone: --- → 1.1 QE5
Assignee: nobody → gghosh
(Reporter)

Comment 1

5 years ago
Created attachment 770002 [details]
adb_logcat

Inari
from v1.0.1 (pvt)
    Gaia:     f000719da5116eca00b78aa8121f38264d3dafee
    Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/9c62297d11b0
    BuildID   20130630070203
    Version   18.0
to v1-train (complete gaia/gecko OTA update)
    Gaia mozillaorg/v1-train - 6ed9316f397dfe09d8fa88506881d1a4e697643a
    Gecko mozillaorg/gecko-18 - 8a1953cec5ba17158bbd715c0647dc5189e4f472

Before OTA, add event "before ota" by Calendar app.
After OTA, blank screen when launch Calendar app.

There are some messages from logcat:
E/GeckoConsole(  719): [JavaScript Error: "DataError: Data provided to an operation does not meet requirements." {file: "app://calendar.gaiamobile.org/js/db.js" line: 318}]
E/GeckoConsole(  719): [JavaScript Error: "AbortError" {file: "app://calendar.gaiamobile.org/js/db.js" line: 88}]
E/GeckoConsole(  719): [JavaScript Error: "TypeError: this.connection is null" {file: "app://calendar.gaiamobile.org/js/db.js" line: 147}]
Can yoi please provide more details on the step where you add an event (what exact details did you fill in? ) and also a screenshot of the event prior to hitting save would be very useful... From there we might be able to track down the error...

I am not sure why we can't reproduce this without the OTA update but I have been unable to see it myself so far.
Flags: needinfo?(fyen)
(Reporter)

Comment 3

5 years ago
Created attachment 770580 [details]
adb_logcat_2

Inari
from v1.0.1 (pvt)
    Gaia:     f000719da5116eca00b78aa8121f38264d3dafee
    Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/9c62297d11b0
    BuildID   20130702070206
    Version   18.0
to v1-train (update url: http://update.boot2gecko.org/inari/1.1.0/nightly/update.xml)
    Gaia:     2c40ccec96271ea9f34aa6fbdfc6563a540548b3
    Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18/rev/4668b32352a8
    BuildID   20130702104756
    Version   18.0

1. Flash inari v1.0.1 pvt build into device.
2. Change update URL to http://update.boot2gecko.org/inari/1.1.0/nightly/update.xml , then reboot.
3. Launch Calendar app.
4. Add event with title "before ota" into Offline calendar.
5. Install v1.1.0 OTA update.
6. After update finish, launch Calendar app. Calendar blank screen.

Youtube: http://youtu.be/M861sIBBiFI 

There are some messages from logcat:
E/GeckoConsole(  820): [JavaScript Error: "DataError: Data provided to an operation does not meet requirements." {file: "app://calendar.gaiamobile.org/gaia_build_defer_index.js" line: 344}]
E/GeckoConsole(  820): [JavaScript Error: "AbortError" {file: "app://calendar.gaiamobile.org/gaia_build_defer_index.js" line: 339}]
E/GeckoConsole(  820): [JavaScript Error: "TypeError: this.connection is null" {file: "app://calendar.gaiamobile.org/gaia_build_defer_index.js" line: 341}]
Flags: needinfo?(fyen)
(Reporter)

Comment 4

5 years ago
(In reply to Askeing Yen[:askeing] from comment #3)
> Youtube: http://youtu.be/M861sIBBiFI 
Youtube: http://youtu.be/zQgI4230SgI
Sorry for the wrong link.

Updated

5 years ago
Whiteboard: [migration] → [migration][TD-55766]

Updated

5 years ago
Target Milestone: 1.1 QE5 → 1.1 QE4 (15jul)
(Assignee)

Comment 5

5 years ago
Created attachment 775250 [details] [diff] [review]
Finds string only calendarId when parseInt fails
Attachment #775250 - Flags: review?(jlal)
Comment on attachment 775250 [details] [diff] [review]
Finds string only calendarId when parseInt fails

please attach a pull request this is a single commit.
Attachment #775250 - Flags: review?(jlal) → review-
(Assignee)

Comment 7

5 years ago
Created attachment 775779 [details] [diff] [review]
Finds string only calendarId when parseInt fails
Attachment #775250 - Attachment is obsolete: true
Attachment #775779 - Flags: review?(jlal)
Comment on attachment 775779 [details] [diff] [review]
Finds string only calendarId when parseInt fails

mostly style nits- looks pretty good please re-flag when your ready for another round.
Attachment #775779 - Flags: review?(jlal) → review-
(Assignee)

Comment 9

5 years ago
Created attachment 776496 [details] [diff] [review]
Finds string only calendarId when parseInt fails
Attachment #775779 - Attachment is obsolete: true
Attachment #776496 - Flags: review?(jlal)
(Assignee)

Comment 10

5 years ago
Created attachment 776547 [details] [diff] [review]
Finds string only calendarId when parseInt fails
Attachment #776496 - Attachment is obsolete: true
Attachment #776496 - Flags: review?(jlal)
Attachment #776547 - Flags: review?(jlal)
Comment on attachment 776547 [details] [diff] [review]
Finds string only calendarId when parseInt fails

in master: https://github.com/mozilla-b2g/gaia/commit/8351189ec721605f572f9f7866df34e425743125
Attachment #776547 - Flags: review?(jlal) → review+
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Keywords: verifyme
QA Contact: jsmith
(Reporter)

Comment 12

5 years ago
Due to it's leo+, it should lands to v1-train.
Uplifted 8351189ec721605f572f9f7866df34e425743125 to:
v1-train: 095143dd4d847af6dbc73d6defbf9c4c94d533ab
status-b2g18: --- → fixed
v1.1.0hd: 095143dd4d847af6dbc73d6defbf9c4c94d533ab
status-b2g-v1.1hd: --- → fixed
(Reporter)

Comment 15

4 years ago
Unagi
from v1.0.1
  Gaia:     054cdc27404e2daca91d3065d9783681032b2151
  Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/9c62297d11b0
  BuildID   20130728070232
  Version   18.0
to v1.1.0 http://update.boot2gecko.org/unagi/1.1.0/nightly/update.xml
  Gaia:     7aaffc8ccb6cf7ddd1e97943c108f1cb9eae5de0
  Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18/rev/e8ded8d2e5cf
  BuildID   20130728070224
  Version   18.0

Verified.
Status: RESOLVED → VERIFIED
status-b2g18: fixed → verified

Updated

4 years ago
Keywords: verifyme

Updated

4 years ago
Duplicate of this bug: 901406

Updated

4 years ago
Whiteboard: [migration][TD-55766] → [migration][LeoVB+]
Depends on: 956592
We should change the name of the suite at https://github.com/mozilla-b2g/gaia/blob/master/apps/calendar/test/unit/db_test.js#L194.

Updated

4 years ago
Blocks: 996413
You need to log in before you can comment on or make changes to this bug.