Closed Bug 887967 Opened 7 years ago Closed 7 years ago

Calendar password prompt fails with Error: "winUtils is null" when calling method: [nsIPromptService2::promptAuth]

Categories

(Toolkit :: General, defect)

24 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla25
Tracking Status
firefox22 --- unaffected
firefox23 --- unaffected
firefox24 --- verified
firefox25 --- verified

People

(Reporter: ssitter, Assigned: markh)

References

Details

(Keywords: regression)

Attachments

(1 file)

Lightning 2.6a2 (BuildID 20130627203815)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Thunderbird/24.0a2

I want to test Bug 887160. After subscribing to a CalDAV calendar I'm not prompted for username and password as expected. Instead nothing happens. The error console shows:

Error: winUtils is null
Source File: resource://gre/components/nsPrompter.js Line: 380

Error: runnablePrompter:run: [Exception... "'[JavaScript Error: "winUtils is null" {file: "resource://gre/components/nsPrompter.js" line: 380}]' when calling method: [nsIPromptService2::promptAuth]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: resource://gre/components/nsLoginManagerPrompter.js :: <TOP_LEVEL> :: line 577"  data: yes]
Source File: resource://gre/components/msgAsyncPrompter.js Line: 29
Mark, could you help to verify if this problem is caused by your changes in Bug 875157? 
At least the reported code location was last touched by this bug.
Keywords: regression
Yep - sorry about that...
Blocks: 762400
OS: Windows 7 → All
Hardware: x86_64 → All
This patch should fix it and seems reasonable to me and still addresses the use-case in bug 762400.

Drew, this is a patch for the "skip prompts from the hidden window" - if the window doesn't support nsIDOMWindowUtils I think it's safe to assume it's not hidden from the POV of our thumbnail work...
Assignee: nobody → mhammond
Attachment #768569 - Flags: review?(adw)
Attachment #768569 - Flags: review?(adw) → review+
https://hg.mozilla.org/mozilla-central/rev/e6b035789ee7
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Lightning 2.7a1 with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Thunderbird/25.0a1 (BuildID 20130628175902)

I can confirm that the problem is fixed. The expected dialog is displayed again.

Could you take care to port back the fix to the affected aurora (mozilla24) branch?
Component: Internal Components → General
Product: Calendar → Toolkit
Target Milestone: --- → mozilla25
Version: Lightning 2.6 → 24 Branch
Comment on attachment 768569 [details] [diff] [review]
Only use winUtils if not null

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 875157
User impact if declined: Lightning (Calendar) product will be broken in Thunderbird
Testing completed (on m-c, etc.): Landed on MC
Risk to taking this patch (and alternatives if risky): Low risk - fixes regression by reverting behaviour back to before bug 875157's patch - and that bug is only required for background thumbnails which aren't yet used directly on the 24 branch
String or IDL/UUID changes made by this patch: None
Attachment #768569 - Flags: approval-mozilla-aurora?
Comment on attachment 768569 [details] [diff] [review]
Only use winUtils if not null

Does anyone happen to know which nsIDOMWindow implementation fails to return an nsIDOMWindowUtils from nsIInterfaceRequestor? I would be curious to know!
Attachment #768569 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
If I read the calendar source code correct the Calendar password prompt will be opened using nsIAuthPrompt2::promptAuth() in http://mxr.mozilla.org/comm-central/source/calendar/base/modules/calAuthUtils.jsm#254

Before that it creates the prompt using nsIPromptFactory::getPrompt() but I'm not sure what object is actually passed in as the nsIDOMWindow aParent argument but it seems to be some calendar object.

When triggering the error in comment 0 the arguments passed to openModalWindow() are:
> domWin=[xpconnect wrapped (nsISupports, calICalendarProvider, nsIInterfaceRequestor, calIFreeBusyProvider, nsIChannelEventSink, calIItipTransport, calISchedulingSupport, calICalendar, calIChangeLog, calICalDavCalendar, nsIDOMWindow)] 
> uri=chrome://global/content/commonDialog.xul 
> args=[xpconnect wrapped (nsISupports, nsIWritablePropertyBag2, nsIWritablePropertyBag)]
Stefan, can you please verify this is working for you now in Thunderbird 24 and 25?
Flags: needinfo?(ssitter)
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #11)
Verified, have not seen any user complaints regarding this problem.
Flags: needinfo?(ssitter)
Thanks for getting back to us, Stefan.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.