Closed Bug 888042 Opened 7 years ago Closed 7 years ago

Page on settings up Remote Debugging

Categories

(Developer Documentation :: Developer Tools, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: liuche, Assigned: wbamberg)

References

Details

We'd like to surface remote debugging in the Android UI (ideally to ship with Fx25), and we need to link to some official non-blog instructions for set-up.

There's a smattering of documentation amongst the JSDebugger and FirefoxOS simulator pages (and also [1] which mentions debugging over wifi), but none of it is specifically relevant to setting up remote debugging on Android, and would probably be confusing to link to.

It's probably too much sharding to make a specific page for Android, so I'd like to figure out what would be best.

[1] https://hacks.mozilla.org/2012/08/remote-debugging-on-firefox-for-android/

And another reference:
[2] http://starkravingfinkle.org/blog/2012/08/firefox-for-android-remote-debugging-is-here/
Thanks for raising this. I'm still trying to catch up with basic coverage for the developer tools, but once that is in a reasonable state will take a look at this and we'll try to figure out what's best.
Thanks for getting the page up, Will!

New docs for remote debugging at (auto-localized link): https://developer.mozilla.org/docs/Tools/Remote_Debugging
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 888536
You need to log in before you can comment on or make changes to this bug.