Closed Bug 888248 Opened 7 years ago Closed 7 years ago

java.lang.NullPointerException: at org.mozilla.gecko.health.BrowserHealthRecorder$<n>.run(BrowserHealthRecorder.java)

Categories

(Firefox for Android :: General, defect)

23 Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 25
Tracking Status
firefox22 --- unaffected
firefox23 --- fixed
firefox24 --- fixed

People

(Reporter: scoobidiver, Assigned: rnewman)

References

Details

(Keywords: crash, regression, Whiteboard: [native-crash])

Crash Data

Attachments

(1 file)

There are 3 reports including bp-24b42641-0186-428b-bd23-588a12130628.

java.lang.NullPointerException
	at org.mozilla.gecko.health.BrowserHealthRecorder$4.run(BrowserHealthRecorder.java:785)
	at android.os.Handler.handleCallback(Handler.java:605)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:137)
	at org.mozilla.gecko.util.GeckoBackgroundThread.run(GeckoBackgroundThread.java:32)

More reports at:
https://crash-stats.mozilla.com/query/?product=FennecAndroid&query_search=signature&query_type=contains&query=org.mozilla.gecko.health.BrowserHealthRecorder&reason=&do_query=1
tracking-fennec: --- → ?
Untested.
Assignee: nobody → rnewman
Status: NEW → ASSIGNED
Attachment #769452 - Flags: review?(nalexander)
Comment on attachment 769452 [details] [diff] [review]
Proposed patch. v1

Review of attachment 769452 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/base/health/BrowserHealthRecorder.java
@@ +783,5 @@
>              @Override
>              public void run() {
> +                final HealthReportDatabaseStorage storage = self.storage;
> +                if (storage == null) {
> +                    Log.d(LOG_TAG, "No storage: shutting down?");

Can you say something less generic, like "No storage: not recording search. Shutting down?"
Attachment #769452 - Flags: review?(nalexander) → review+
https://hg.mozilla.org/services/services-central/rev/d8d375e82d13
Whiteboard: [native-crash] → [native-crash][fixed in services]
https://hg.mozilla.org/mozilla-central/rev/d8d375e82d13
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [native-crash][fixed in services] → [native-crash]
Target Milestone: --- → Firefox 25
Comment on attachment 769452 [details] [diff] [review]
Proposed patch. v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
  Initial FHR landing.

User impact if declined: 
  Some number of crashes.

Testing completed (on m-c, etc.): 
  Landed on m-c; can't really verify until we see whether crash rate goes down.

Risk to taking this patch (and alternatives if risky): 
  Should be none: just null checks.

String or IDL/UUID changes made by this patch:
  None.
Attachment #769452 - Flags: approval-mozilla-beta?
Attachment #769452 - Flags: approval-mozilla-aurora?
Comment on attachment 769452 [details] [diff] [review]
Proposed patch. v1

Early enough in the cycle to take a fix for a non-topcrash null check.
Attachment #769452 - Flags: approval-mozilla-beta?
Attachment #769452 - Flags: approval-mozilla-beta+
Attachment #769452 - Flags: approval-mozilla-aurora?
Attachment #769452 - Flags: approval-mozilla-aurora+
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.