Transparency in PDF files in Firefox 22

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: jaredbski, Unassigned)

Tracking

22 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-smask][pdfjs-f-fixed-upstream]https://github.com/mozilla/pdf.js/pull/3439#issuecomment-20702451)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 769086 [details]
Transparencies not displayed properly in Firefox

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

I uploaded a PDF with transparent PNGs embedded.  Internet Explorer and Chrome display the PDF with no issues.


Actual results:

Firefox doesn't keep the transparency. Having this file display with transparencies is important for students in the Boise VA Medical Center's interdisciplinary training programs. I shouldn't have to mandate that they use another browser besides Firefox.


Expected results:

Keep the transparency in the PDF. Firefox needs to fix its built-in PDF viewer. I saw a similar sounding issue in bugzilla that said it was resolved for Firefox 19, but I'm having the same problem in Firefox 22.
(Reporter)

Comment 1

5 years ago
Thanks for your help!
Keywords: common-issue+

Updated

5 years ago
Component: Untriaged → PDF Viewer

Comment 2

5 years ago
Your PDF has 145 pages, so could you indicate where is the issue is visible? (attach a screenshot if possible)

The PDF sample looks good for me.
Flags: needinfo?(jaredbski)
Keywords: common-issue+
Looks like issue is on page 16.  OSX on preview seems to have the same issue.
Priority: -- → P3
Whiteboard: [pdfjs-c-rendering][pdfjs-d-smask]
(Reporter)

Comment 4

5 years ago
I uploaded a PDF where you can see the problem easier: http://go.va.gov/j5cw. Again, the transparency for certain files doesn't render in Firefox but does render properly in Acrobat Reader, Internet Explorer, and Google Chrome.
Flags: needinfo?(jaredbski)

Comment 5

5 years ago
(In reply to Jared from comment #4)
> I uploaded a PDF where you can see the problem easier:
> http://go.va.gov/j5cw. Again, the transparency for certain files doesn't
> render in Firefox but does render properly in Acrobat Reader, Internet
> Explorer, and Google Chrome.

URL is broken.
Flags: needinfo?(jaredbski)
(Reporter)

Comment 6

5 years ago
(In reply to Loic from comment #5)
> (In reply to Jared from comment #4)
> > I uploaded a PDF where you can see the problem easier:
> > http://go.va.gov/j5cw. Again, the transparency for certain files doesn't
> > render in Firefox but does render properly in Acrobat Reader, Internet
> > Explorer, and Google Chrome.
> 
> URL is broken.

Sorry, here's a working URL: http://idjared.com/transparency_in_firefox.pdf. This file has 4 pages that show the transparency issue.
Flags: needinfo?(jaredbski)

Updated

5 years ago
Whiteboard: [pdfjs-c-rendering][pdfjs-d-smask] → [pdfjs-c-rendering][pdfjs-d-smask][pdfjs-f-fixed-upstream]https://github.com/mozilla/pdf.js/pull/3439#issuecomment-20702451
Reproduced on Fx 24 beta 7:
(20130829135643) Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

Not reproduced on latest Aurora and Nightly:
(20130901004005) Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0
(20130901030218) Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
(In reply to petruta.rasa from comment #8)

> Not reproduced on latest Aurora and Nightly:
> (20130901004005) Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101
> Firefox/25.0
> (20130901030218) Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101
> Firefox/26.0

Confirmed attachment 770341 [details] being fixed on Firefox 25 and newer.

"PDF 7234f111b005c433cbb9884e125e01e [1.4 Adobe Acrobat Pro 10.1.7 / Adobe Acrobat Pro 10.1.7] (PDF.js: 0.8.377)"
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Comment 10

5 years ago
Fixed by bug 897554.
Depends on: 897554
You need to log in before you can comment on or make changes to this bug.