Last Comment Bug 888478 - DOM Inspector could not be installed
: DOM Inspector could not be installed
Status: RESOLVED FIXED
: relnote
Product: SeaMonkey
Classification: Client Software
Component: Build Config (show other bugs)
: SeaMonkey 2.19 Branch
: x86_64 Windows 7
: -- normal (vote)
: seamonkey2.23
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 914560
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-28 14:02 PDT by Peter B. Shalimoff
Modified: 2014-01-07 07:43 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
affected
affected


Attachments
inspector@mozilla.org.xpi (273.60 KB, application/x-xpinstall)
2013-06-28 14:02 PDT, Peter B. Shalimoff
no flags Details

Description Peter B. Shalimoff 2013-06-28 14:02:56 PDT
Created attachment 769152 [details]
inspector@mozilla.org.xpi

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 SeaMonkey/2.19 (Beta/Release)
Build ID: 20130625001820

Steps to reproduce:

Tried to manually install DOM Inspector from the distribution/extensions folder (since it's not installed by default). Used a brand new profile with default settings.


Actual results:

The browser says "The add-on downloaded from unknown host could not be installed because it appears to be corrupt". Tried the following - the story is the same:
1) dropping the xpi in a browser window
2) using "Install add-on from file" in the add-on manager
3) using File -> Open File.
Tested the xpi with WinRAR and 7-Zip - no errors found.
Comment 1 Philip Chee 2013-06-29 04:39:53 PDT
Comment on attachment 769152 [details]
inspector@mozilla.org.xpi

Yep, looks like the install.rdf is missing.
Comment 2 Philip Chee 2013-06-29 04:44:21 PDT
How about debugQA@mozilla.org.xpi in your distribution directory? Is it also missing a install.rdf?
Comment 3 Philip Chee 2013-06-29 04:49:10 PDT
Where exactly did you get this seamonkey build from? File name and location (ftp?) would be appreciated.
Comment 4 Peter B. Shalimoff 2013-06-29 06:09:33 PDT
I got this build from here:
http://www.seamonkey-project.org/
-> http://www.seamonkey-project.org/releases/2.19b2
-> https://download.mozilla.org/?product=seamonkey-2.19b2&os=win&lang=en-US
-> http://download.cdn.mozilla.net/pub/mozilla.org/seamonkey/releases/2.19b2/win32/en-US/SeaMonkey%20Setup%202.19b2.exe
The file size is 22284675 bytes, the MD5 and SHA1 checksums match those provided on the download page.

I don't have debugQA@mozilla.org.xpi in my distribution directory. Besides inspector@mozilla.org.xpi, there're two extensions: Chatzilla ({59c81df5-4b7a-477b-912d-4e0fdf64e5f2}.xpi) and Venkman ({f13b157f-b174-47e7-a34d-4815ddfdfeb8}.xpi). Both have install.rdf, and both were installed by default.
Comment 5 Philip Chee 2013-06-29 10:43:06 PDT
Thanks. I can confirm that the DOM Inspector shipped with the SeaMonkey 2.19b2 installer is missing the install.rdf
Comment 6 Peter B. Shalimoff 2013-06-29 12:54:19 PDT
The latest "stable" release 2.17.1 is missing it as well (as do 2.19b1 and 2.16). So I installed it from here: https://addons.mozilla.org/en-US/firefox/addon/dom-inspector-6622/
Comment 7 Justin Wood (:Callek) 2013-06-30 00:36:12 PDT
Ok, I'm not going to solve this in time for 2.19's final release.

Jens, can you relnote with the recommendation of installing direct-from-AMO for users who are affected. This only affects *new* profiles, not existing (if they have DOMi already).

=============

Now in trying to fix it; the seamonkey log file shows:

Packaging inspector-2.0.15pre.xpi...
e:\builds\slave\rel-c-beta-w32-bld\build\mozilla\config\rules.mk:1586:0$ cd ../../dist/xpi-stage/inspector && zip -qr ../inspector-2.0.15pre.xpi *
e:\builds\slave\rel-c-beta-w32-bld\build\mozilla\config\rules.mk:1595:0$ rm -f -r "../../dist/bin/extensions/inspector@mozilla.org"
e:\builds\slave\rel-c-beta-w32-bld\build\mozilla\config\rules.mk:1596:0$ e:/builds/slave/rel-c-beta-w32-bld/build/objdir/mozilla/_virtualenv/Scripts/python.exe e:/builds/slave/rel-c-beta-w32-bld/build/mozilla/config/nsinstall.py -D "../../dist/bin/extensions/inspector@mozilla.org"
e:\builds\slave\rel-c-beta-w32-bld\build\mozilla\config\rules.mk:1597:0$ (cd ../../dist/xpi-stage/inspector/. && tar -chf - .) | (cd ../../dist/bin/extensions/inspector@mozilla.org/. && tar -xf -)
evaluation from e:\builds\slave\rel-c-beta-w32-bld\build\mozilla\config\rules.mk:1729:4:2:0$ rm -f "../../dist/xpi-stage/inspector/defaults/preferences/inspector.js"
evaluation from e:\builds\slave\rel-c-beta-w32-bld\build\mozilla\config\rules.mk:1729:4:3:0$ e:/builds/slave/rel-c-beta-w32-bld/build/objdir/mozilla/_virtualenv/Scripts/python.exe e:/builds/slave/rel-c-beta-w32-bld/build/mozilla/config/Preprocessor.py  --line-endings=crlf -DRELEASE_BUILD -DXPI_NAME=inspector -DMOZ_SUITE=1 -DNO_NSPR_10_SUPPORT -D_CRT_SECURE_NO_WARNINGS=1 -D_CRT_NONSTDC_NO_WARNINGS=1 -DHAVE_SEH_EXCEPTIONS=1 -DHAVE_WINSDKVER_H=1 -DMOZ_MSVC_STL_WRAP__RAISE=1 -DWINVER=0x502 -D_WIN32_WINNT=0x502 -D_WIN32_IE=0x0603 -DMOZ_WINSDK_TARGETVER=0x06010000 -DMOZ_NTDDI_WIN7=0x06010000 -DHAVE_IO_H=1 -DHAVE_SETBUF=1 -DHAVE_ISATTY=1 -DX_DISPLAY_MISSING=1 -DJSGC_INCREMENTAL=1 -DMOZ_ENABLE_PROFILER_SPS=1 -DMOZILLA_VERSION=\"22.0\" -DMOZILLA_VERSION_U=22.0 -DMOZILLA_UAVERSION=\"22.0\" -DHAVE_SNPRINTF=1 -D_WINDOWS=1 -DWIN32=1 -DXP_WIN=1 -DXP_WIN32=1 -DHW_THREADS=1 -DSTDC_HEADERS=1 -DWIN32_LEAN_AND_MEAN=1 -DNO_X11=1 -DHAVE_STDCALL=1 -D_X86_=1 -DD_INO=d_ino -DNS_ATTR_MALLOC= -DNS_WARN_UNUSED_RESULT= -DMALLOC_H=\<malloc.h\> -DHAVE_FORCEINLINE=1 -DHAVE_LOCALECONV=1 -DNS_ENABLE_TSF=1 -DMOZ_UPDATE_CHANNEL=beta -DMOZ_BUILD_APP=../suite -DMOZ_PDF_PRINTING=1 -DMOZ_INSTRUMENT_EVENT_LOOP=1 -DMOZ_DISTRIBUTION_ID=\"org.mozilla\" -DIBMBIDI=1 -DACCESSIBILITY=1 -DNS_PRINTING=1 -DNS_PRINT_PREVIEW=1 -DMOZ_SAMPLE_TYPE_FLOAT32=1 -DMOZ_WEBSPEECH=1 -DMOZ_OGG=1 -DMOZ_WEBM=1 -DMOZ_WMF=1 -DMOZ_MEDIA_NAVIGATOR=1 -DMOZ_VP8=1 -DVPX_X86_ASM=1 -DMOZ_WAVE=1 -DMOZ_SPEEX_RESAMPLER=1 -DMOZ_SOUNDTOUCH=1 -DMOZ_CUBEB=1 -DMOZ_MEDIA=1 -DMOZ_VORBIS=1 -DMOZ_OPUS=1 -DMOZ_WEBVTT=1 -DENABLE_SYSTEM_EXTENSION_DIRS=1 -DMOZ_CRASHREPORTER=1 -DMOZ_CRASHREPORTER_INJECTOR=1 -DBREAKPAD_CUSTOM_STDINT_H=\"mozilla/StandardInteger.h\" -DMOZ_CRASHREPORTER_ENABLE_PERCENT=100 -DLIBJPEG_TURBO_X86_ASM=1 -DMOZ_FLEXBOX=1 -DMOZ_UPDATER=1 -DMOZ_FEEDS=1 -DMOZ_HELP_VIEWER=1 -DMOZ_URL_CLASSIFIER=1 -DGL_PROVIDER_=1 -DMOZ_DEBUG_SYMBOLS=1 -DMOZ_LOGGING=1 -DMOZ_MEMORY_SIZEOF_PTR_2POW=2 -DMOZ_MEMORY=1 -DMOZ_MEMORY_WINDOWS=1 -DJSGC_INCREMENTAL=1 -DJS_DEFAULT_JITREPORT_GRANULARITY=3 -DMOZ_OMNIJAR=1 -DMOZ_USER_DIR=\"Mozilla\" -DMOZ_TREE_PIXMAN=1 -DHAVE_STDINT_H=1 -DMOZ_TREE_CAIRO=1 -DHAVE_UINT64_T=1 -DMOZ_ENABLE_SKIA=1 -DUSE_SKIA=1 -DSKIA_DLL=1 -DGR_DLL=1 -DUSE_SKIA_GPU=1 -DMOZ_XUL=1 -DMOZ_PROFILELOCKING=1 -DBUILD_CTYPES=1 -DMOZ_PLACES=1 -DMOZ_SERVICES_COMMON=1 -DMOZ_SERVICES_CRYPTO=1 -DMOZ_SERVICES_SYNC=1 -DMOZ_APP_COMPONENT_MODULES=MODULE\(xpAutoComplete\)\ MODULE\(nsMailModule\)\ MODULE\(nsMsgSMIMEModule\)\ MODULE\(nsImportServiceModule\)\ MODULE\(msgMapiModule\)\ MODULE\(nsLDAPProtocolModule\)\ MODULE\(nsMorkModule\) -DMOZ_MACBUNDLE_ID=org.mozilla.seamonkey -DMOZ_B2G_VERSION=\"1.0.0\" -DMOZ_B2G_OS_NAME=\"\" -DMOZ_APP_UA_NAME=\"\" -DMOZ_APP_UA_VERSION=\"2.19\" -DFIREFOX_VERSION=22.0 -DMOZ_UA_BUILDID=\"20100101\" -DMOZ_TELEMETRY_DISPLAY_REV=2 -DMOZ_DATA_REPORTING=1 -DMOZ_DLL_SUFFIX=\".dll\" -DNDEBUG -DTRIMMED "e:/builds/slave/rel-c-beta-w32-bld/build/mozilla/extensions/inspector/resources/content/prefs/inspector.js" -o "../../dist/xpi-stage/inspector/defaults/preferences/inspector.js"
evaluation from e:\builds\slave\rel-c-beta-w32-bld\build\mozilla\config\rules.mk:1729:4:2:0$ rm -f "../../dist/xpi-stage/inspector/install.rdf"
evaluation from e:\builds\slave\rel-c-beta-w32-bld\build\mozilla\config\rules.mk:1729:4:3:0$ e:/builds/slave/rel-c-beta-w32-bld/build/objdir/mozilla/_virtualenv/Scripts/python.exe e:/builds/slave/rel-c-beta-w32-bld/build/mozilla/config/Preprocessor.py  -DDOMi_VERSION=2.0.15pre  -DXPI_NAME=inspector -DMOZ_SUITE=1 -DNO_NSPR_10_SUPPORT -D_CRT_SECURE_NO_WARNINGS=1 -D_CRT_NONSTDC_NO_WARNINGS=1 -DHAVE_SEH_EXCEPTIONS=1 -DHAVE_WINSDKVER_H=1 -DMOZ_MSVC_STL_WRAP__RAISE=1 -DWINVER=0x502 -D_WIN32_WINNT=0x502 -D_WIN32_IE=0x0603 -DMOZ_WINSDK_TARGETVER=0x06010000 -DMOZ_NTDDI_WIN7=0x06010000 -DHAVE_IO_H=1 -DHAVE_SETBUF=1 -DHAVE_ISATTY=1 -DX_DISPLAY_MISSING=1 -DJSGC_INCREMENTAL=1 -DMOZ_ENABLE_PROFILER_SPS=1 -DMOZILLA_VERSION=\"22.0\" -DMOZILLA_VERSION_U=22.0 -DMOZILLA_UAVERSION=\"22.0\" -DHAVE_SNPRINTF=1 -D_WINDOWS=1 -DWIN32=1 -DXP_WIN=1 -DXP_WIN32=1 -DHW_THREADS=1 -DSTDC_HEADERS=1 -DWIN32_LEAN_AND_MEAN=1 -DNO_X11=1 -DHAVE_STDCALL=1 -D_X86_=1 -DD_INO=d_ino -DNS_ATTR_MALLOC= -DNS_WARN_UNUSED_RESULT= -DMALLOC_H=\<malloc.h\> -DHAVE_FORCEINLINE=1 -DHAVE_LOCALECONV=1 -DNS_ENABLE_TSF=1 -DMOZ_UPDATE_CHANNEL=beta -DMOZ_BUILD_APP=../suite -DMOZ_PDF_PRINTING=1 -DMOZ_INSTRUMENT_EVENT_LOOP=1 -DMOZ_DISTRIBUTION_ID=\"org.mozilla\" -DIBMBIDI=1 -DACCESSIBILITY=1 -DNS_PRINTING=1 -DNS_PRINT_PREVIEW=1 -DMOZ_SAMPLE_TYPE_FLOAT32=1 -DMOZ_WEBSPEECH=1 -DMOZ_OGG=1 -DMOZ_WEBM=1 -DMOZ_WMF=1 -DMOZ_MEDIA_NAVIGATOR=1 -DMOZ_VP8=1 -DVPX_X86_ASM=1 -DMOZ_WAVE=1 -DMOZ_SPEEX_RESAMPLER=1 -DMOZ_SOUNDTOUCH=1 -DMOZ_CUBEB=1 -DMOZ_MEDIA=1 -DMOZ_VORBIS=1 -DMOZ_OPUS=1 -DMOZ_WEBVTT=1 -DENABLE_SYSTEM_EXTENSION_DIRS=1 -DMOZ_CRASHREPORTER=1 -DMOZ_CRASHREPORTER_INJECTOR=1 -DBREAKPAD_CUSTOM_STDINT_H=\"mozilla/StandardInteger.h\" -DMOZ_CRASHREPORTER_ENABLE_PERCENT=100 -DLIBJPEG_TURBO_X86_ASM=1 -DMOZ_FLEXBOX=1 -DMOZ_UPDATER=1 -DMOZ_FEEDS=1 -DMOZ_HELP_VIEWER=1 -DMOZ_URL_CLASSIFIER=1 -DGL_PROVIDER_=1 -DMOZ_DEBUG_SYMBOLS=1 -DMOZ_LOGGING=1 -DMOZ_MEMORY_SIZEOF_PTR_2POW=2 -DMOZ_MEMORY=1 -DMOZ_MEMORY_WINDOWS=1 -DJSGC_INCREMENTAL=1 -DJS_DEFAULT_JITREPORT_GRANULARITY=3 -DMOZ_OMNIJAR=1 -DMOZ_USER_DIR=\"Mozilla\" -DMOZ_TREE_PIXMAN=1 -DHAVE_STDINT_H=1 -DMOZ_TREE_CAIRO=1 -DHAVE_UINT64_T=1 -DMOZ_ENABLE_SKIA=1 -DUSE_SKIA=1 -DSKIA_DLL=1 -DGR_DLL=1 -DUSE_SKIA_GPU=1 -DMOZ_XUL=1 -DMOZ_PROFILELOCKING=1 -DBUILD_CTYPES=1 -DMOZ_PLACES=1 -DMOZ_SERVICES_COMMON=1 -DMOZ_SERVICES_CRYPTO=1 -DMOZ_SERVICES_SYNC=1 -DMOZ_APP_COMPONENT_MODULES=MODULE\(xpAutoComplete\)\ MODULE\(nsMailModule\)\ MODULE\(nsMsgSMIMEModule\)\ MODULE\(nsImportServiceModule\)\ MODULE\(msgMapiModule\)\ MODULE\(nsLDAPProtocolModule\)\ MODULE\(nsMorkModule\) -DMOZ_MACBUNDLE_ID=org.mozilla.seamonkey -DMOZ_B2G_VERSION=\"1.0.0\" -DMOZ_B2G_OS_NAME=\"\" -DMOZ_APP_UA_NAME=\"\" -DMOZ_APP_UA_VERSION=\"2.19\" -DFIREFOX_VERSION=22.0 -DMOZ_UA_BUILDID=\"20100101\" -DMOZ_TELEMETRY_DISPLAY_REV=2 -DMOZ_DATA_REPORTING=1 -DMOZ_DLL_SUFFIX=\".dll\" -DNDEBUG -DTRIMMED "e:/builds/slave/rel-c-beta-w32-bld/build/mozilla/extensions/inspector/install.rdf" -o "../../dist/xpi-stage/inspector/install.rdf"
e:/builds/slave/rel-c-beta-w32-bld/build/mozilla/extensions/inspector/resources/content/prefs/inspector.js: WARNING: no preprocessor directives found
make.py[6]: Leaving directory 'e:\builds\slave\rel-c-beta-w32-bld\build\objdir\mozilla\extensions\inspector'

----------

The Makefile we use here is http://hg.mozilla.org/dom-inspector/file/default/Makefile.in which uses m-c's config/rules.mk from a CWD of mozilla/extensions/inspector

it sets DIST_FILES := install.rdf

https://hg.mozilla.org/releases/mozilla-release/diff/4d183847fc69/config/rules.mk changed the way DIST_FILES works, by moving its behavior inside the PP_TARGETS var/rule.

Then https://hg.mozilla.org/releases/mozilla-release/diff/3afb865b87e6/config/rules.mk added a <C>_TARGET variable that looks to have defaulted to libs.

And yet my log above does the packaging (which happens as part of libs at https://hg.mozilla.org/releases/mozilla-release/annotate/4801440b8b83/config/rules.mk#l1554) occurs before the install.rdf is generated.

So the bottom line is I'm either missing something semi-obvious or there is a real bug here I should have seen. :glandium any ideas you can help with?
Comment 8 Jens Hatlak (:InvisibleSmiley) 2013-06-30 13:21:01 PDT
Relnoted for SM 2.19.
Comment 9 Mike Hommey [:glandium] 2013-07-01 19:43:44 PDT
double-colon rules for a same target are executed in the order they appear.

So the packaging rule happens before the PP_TARGETS rules (which are generated in https://hg.mozilla.org/releases/mozilla-release/annotate/4801440b8b83/config/rules.mk#l1720 )
Comment 10 rsx11m 2013-09-19 12:25:00 PDT
BTW: The Linux release (looking at seamonkey-2.21.tar.bz2's version of inspector@mozilla.org.xpi) does *not* exhibit the problem, an install.rdf was packaged here.
Comment 11 Frank Wein [:mcsmurf] 2013-09-20 00:10:28 PDT
The Windows version of SeaMonkey 2.21 is still affected, install.rdf is missing there.
BTW: The last SeaMonkey 2.23 nightly build (before uplift to 2.24) does not seem to be affected, possibly because of the other build changes during that cycle (bug 914560).
Comment 12 Frank Wein [:mcsmurf] 2013-10-29 06:26:43 PDT
SeaMonkey 2.22 beta 2 also seems to be affected (but SeaMonkey 2.23 should not...).
Comment 13 Peter B. Shalimoff 2013-12-26 23:59:38 PST
I updated from 2.19 to 2.23, and it was installed as usual (version 2.0.15pre).
Comment 14 Philip Chee 2014-01-07 07:43:09 PST
This was fixed in Core::Build Config Bug 914560 (Package XPI extensions during tools phase so that all required files are in place when running the packaging step) and should be working for SeaMonkey 2.23 and later.

Note You need to log in before you can comment on or make changes to this bug.