slow motion sound when playing m4a

RESOLVED DUPLICATE of bug 875644

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 875644
4 years ago
4 years ago

People

(Reporter: jazza cook, Unassigned)

Tracking

22 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.10 MB, application/octet-stream
Details
(Reporter)

Description

4 years ago
Created attachment 769516 [details]
Bells4.m4a

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

building intranet website with podcasts - 
I found directly clicking RSS media links as displayed in FF: 
1. mp4 videos play directly in ff 22 on w8 BUT 
2. audio only m4a files play back in slow motion


Actual results:

Clicking the file.mp4 link - a darkened page opens with dark player. Clicking play starts to play the media but the file plays back in slow motion.


Expected results:

I expected the file to play at normal speed;). 

I'm an HTML5 newbie. I'm not sure if this is a bug or a feature.
I couldn't find any indication of limitations to the AAC files FF can play when searching the web.

The file plays correctly in VLC etc.
I suppose something about the encoding of the m4a file causes the problem.  

I tried 
AddType audio/mp4 m4a .m4a or
AddType audio/x-m4a m4a .m4a in .htaccess
but this changed nothing. 
VLC reports the m4a file is AAC SBR+PS, encoded by Lavf53.21.1

I enclose a sample m4a.

Updated

4 years ago
Blocks: 837859
Component: Untriaged → Video/Audio
Product: Firefox → Core
A dupe of bug 875644. Thanks for taking the time to report this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 875644
You need to log in before you can comment on or make changes to this bug.