Closed Bug 888791 Opened 9 years ago Closed 9 years ago

[Test][System] Unit test for Keyboard Manager

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:-)

RESOLVED DUPLICATE of bug 912010
blocking-b2g -

People

(Reporter: alive, Assigned: GaryChen)

References

Details

Due to recent keyboard regression I think we need unit test for keyboard manager.
This is relevant to WindowManager:setAppSize and/or AppWindow:resize.
take it since this align to 1.2 milestone
Assignee: nobody → gasolin
Assignee: gasolin → nobody
blocking-b2g: --- → koi?
Does not block release.  minusing.  Tests can land without approval.
blocking-b2g: koi? → -
Assignee: nobody → gchen
Stolen from Gary.
Assignee: gchen → lchang
Since bug 912010, KM will be changed and I will review this patch.
I am more familiar with new KM code than Luke so take it back.
Assignee: lchang → gchen
Corey has refactored KM + KH and also add has complete unit test on these two files.

Corey's got r+ and ready to land in gaia master so set to duplicate on bug 912010.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 912010
You need to log in before you can comment on or make changes to this bug.