Java won't load Runescape applet in Firefox Nightly 25.0a1(6-30), works in other browsers

VERIFIED FIXED in Firefox 23

Status

()

defect
P2
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: thedan1313, Assigned: johns)

Tracking

({regression})

23 Branch
mozilla25
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox22 unaffected, firefox23 verified, firefox24 verified, firefox25+ verified, firefox-esr1723+ verified)

Details

()

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130630 Firefox/25.0 (Nightly/Aurora)
Build ID: 20130630031138

Steps to reproduce:

Clicked on the button on the homepage to load the game applet, got a Java error.


Actual results:

Resource http://www.runescape.com/img/game/splash2.gif has future expires: Sun Apr 27 02:37:19 CDT 2014 update check skipped.
Resource http://www.runescape.com/img/game/splash2.gif has future expires: Sun Apr 27 02:37:19 CDT 2014 update check skipped.
CacheEntry[http://world63.runescape.com
Java error, popup.

Console reads:
/,f5367568410822687588,iDBXPZaBPotHnzeZldoHBTxXnbnMFe3VcAAAAAAA-Rs2Applet.class]: updateAvailable=false,lastModified=Wed Dec 31 18:00:00 CST 1969,length=39207
Java Plug-in 10.25.2.17
Using JRE version 1.7.0_25-b17 Java HotSpot(TM) Client VM
User home directory = C:\Users\[snip]


Expected results:

Game should load. Using latest Java, having no issues in Chrome or Opera (Both up to date).
Messed up this section, not sure how to edit OP

Java error, popup.

Console reads:

Resource http://www.runescape.com/img/game/splash2.gif has future expires: Sun Apr 27 02:37:19 CDT 2014 update check skipped.
Resource http://www.runescape.com/img/game/splash2.gif has future expires: Sun Apr 27 02:37:19 CDT 2014 update check skipped.
CacheEntry[http://world63.runescape.com
/,f5367568410822687588,iDBXPZaBPotHnzeZldoHBTxXnbnMFe3VcAAAAAAA-Rs2Applet.class]: updateAvailable=false,lastModified=Wed Dec 31 18:00:00 CST 1969,length=39207
Java Plug-in 10.25.2.17
Using JRE version 1.7.0_25-b17 Java HotSpot(TM) Client VM
User home directory = C:\Users\[snip]
I've got instead the following prompt error: "Incompatible magic value 1013478509 in class file Rs2Applet".
Status: UNCONFIRMED → NEW
Component: Untriaged → Plug-ins
Ever confirmed: true
Product: Firefox → Core
Hardware: x86_64 → x86
I get the exact same thing, it should be in the op but I messed up that section. Any clue what could be causing it? This Java applet has a different error: http://fallingsandgame.com/sand/pyro2.html

But this one works: https://minecraft.net/demo
Would you be able to narrow down when this started to happen?
We have an automated tool for this:
http://mozilla.github.io/mozregression/
Can someone add bug 738396 as blocking, I'm not allowed to do it.
johns, can you take a look?
Priority: -- → P2
@Georg It started early in the morning Saturday (GMT-6). I updated nightly and the error appeared.
Assignee: nobody → jschoenick
Ran the regression tool, the first bad Nightly was 06-29. Thanks for looking into this by the way.
Blocks: 738396
> java.io.FileNotFoundException: http://fallingsandgame.com/sand/pyro2.html/PS.jar

Because we are now explicit about the codebase, we send java the document base URI |http://fallingsandgame.com/sand/pyro2.html|. The applet specifies |archive=PS.jar|. The relative URI |PS.jar| with base |http://fallingsandgame.com/sand/pyro2.html| should be |http://fallingsandgame.com/sand/PS.jar|, but java reaches the brilliant URI |http://fallingsandgame.com/sand/pyro2.html/PS.jar|
OS: Windows 7 → All
Hardware: x86 → All
Attachment #769869 - Flags: review?(joshmoz) → review+
Comment on attachment 769869 [details] [diff] [review]
Java sees no-explicit-codebase as . not baseURI

https://hg.mozilla.org/integration/mozilla-inbound/rev/1f09176d269b
Attachment #769869 - Flags: checkin+
https://hg.mozilla.org/mozilla-central/rev/1f09176d269b
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
Dan - thanks for catching this, it should be fixed in tomorrow's nightly. Let us know if you discover otherwise!
No problem, glad to hear it'll be fixed
Verified fixed nightly 25.0a1 (2013-07-04) Win 7 x64.
Status: RESOLVED → VERIFIED
Everything is working on my end. Thanks for getting this fixed.
Lukas, would it be possible to get this uplifted to Beta? It's possible in doing so bug 582097 might be fixed as well.
Flags: needinfo?(lsblakk)
Comment on attachment 769869 [details] [diff] [review]
Java sees no-explicit-codebase as . not baseURI

Ack, my bad, I had meant to fold this into the 738396 patch and mentioned there that it would be.

[Approval Request Comment]
If this is not a sec:{high,crit} bug, please state case for ESR consideration:
Fixes regression uplifted from a sec bug

Bug caused by (feature/regressing bug #): 
738396

User impact if declined: 
Some broken java

Testing completed (on m-c, etc.): 
Was found on m-c days after 738396 landing and fixed, with no further regressions found. I neglected to track it properly for uplift along with 738396 :(

Risk to taking this patch (and alternatives if risky): 
Very low, fixes one missed edge case from 738396. Only interacts with java applets.

String or IDL/UUID changes made by this patch:
None
Attachment #769869 - Flags: approval-mozilla-esr17?
Attachment #769869 - Flags: approval-mozilla-beta?
Attachment #769869 - Flags: approval-mozilla-aurora?
This is marked as unaffected in 24 (and thus assumed to be unaffected in 23 as well) and comment 9 says it first showed up in a 6-29 Nightly which is FF25 regression - I don't see the reason to uplift this, can you make a case for why?
Flags: needinfo?(lsblakk) → needinfo?(anthony.s.hughes)
Comment on attachment 769869 [details] [diff] [review]
Java sees no-explicit-codebase as . not baseURI

This doesn't meet ESR criteria (https://wiki.mozilla.org/Release_Management/ESR_Landing_Process) unless there's a significant user impact to make a case for getting this uplifted to FF24 (Aurora) to ensure it goes into our next ESR release.
Attachment #769869 - Flags: approval-mozilla-esr17? → approval-mozilla-esr17-
(In reply to lsblakk@mozilla.com [:lsblakk] from comment #20)
> I don't see the reason to uplift this, can you make a case for why?

See bug 582097 comment 4 and 5. If you need more info than that please need-info bsmedberg.
Flags: needinfo?(anthony.s.hughes)
(In reply to lsblakk@mozilla.com [:lsblakk] from comment #21)
> Comment on attachment 769869 [details] [diff] [review]
> Java sees no-explicit-codebase as . not baseURI
> 
> This doesn't meet ESR criteria
> (https://wiki.mozilla.org/Release_Management/ESR_Landing_Process) unless
> there's a significant user impact to make a case for getting this uplifted
> to FF24 (Aurora) to ensure it goes into our next ESR release.

We regressed this by uplifting bug 738396, it's a new regression in those branches. This patch is trivial and was going to be folded into the 738396 patch (see bug 738396 comment 49) but I neglected to.
Flags: needinfo?(lsblakk)
Attachment #769869 - Flags: approval-mozilla-beta?
Attachment #769869 - Flags: approval-mozilla-beta+
Attachment #769869 - Flags: approval-mozilla-aurora?
Attachment #769869 - Flags: approval-mozilla-aurora+
Thanks John, approved on branches !
Flags: needinfo?(lsblakk)
Comment on attachment 769869 [details] [diff] [review]
Java sees no-explicit-codebase as . not baseURI

Re-nominating per clarification in comment 23
Attachment #769869 - Flags: approval-mozilla-esr17- → approval-mozilla-esr17?
Version: 25 Branch → 23 Branch
Verified as fixed on Firefox 23 beta 8 (no error is encountered when playing Runescape)
Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20100101 Firefox/23.0
Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20100101 Firefox/23.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:23.0) Gecko/20100101 Firefox/23.0
Build ID: 20130722172257
QA Contact: simona.marcu
(In reply to Simona B [QA] from comment #27)
> Verified as fixed on Firefox 23 beta 8 (no error is encountered when playing
> Runescape)
> Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20100101 Firefox/23.0
> Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20100101 Firefox/23.0
> Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:23.0) Gecko/20100101
> Firefox/23.0
> Build ID: 20130722172257

Verified using Java 7 Update 25.
Attachment #769869 - Flags: approval-mozilla-esr17? → approval-mozilla-esr17+
Simona, would you be able to verify this in the 17.0.8esr build candidate? Thank you.

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/17.0.8esr-candidates/build1/
Status: VERIFIED → RESOLVED
Closed: 6 years ago6 years ago
(In reply to Matt Wobensmith from comment #30)
> Simona, would you be able to verify this in the 17.0.8esr build candidate?
> Thank you.
> 
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/17.0.8esr-candidates/
> build1/

Verified as fixed on Fierefox 17.0.8 esr:
Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20100101 Firefox/17.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20130729214632
Verified fixed Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0b1
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.