Closed Bug 888836 Opened 6 years ago Closed 6 years ago

Firefox Beta stops playing downloaded mp3s when android screen is locked

Categories

(Firefox for Android :: General, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 25
Tracking Status
firefox23 --- verified
firefox24 --- verified
firefox25 --- verified

People

(Reporter: freddyb, Assigned: wesj)

References

Details

(Keywords: regression)

Attachments

(2 files)

This happens only in beta, not in the release version of Firefox.

STR:
1. Click on an MP3 link (the file is opened in the same window, audio controls show up. it starts downloading and starts to play)
1a. Actually, it could be that you have to click play manually...
3. Lock the Android Screen
4. The audio stops

On the release version, the audio keeps playing..
I saw this the other day too on NPR.com. Its from bug 809558. I'm going to look into disable audioChannels in non-webapps.
Blocks: 809558
Keywords: regression
Attached patch PatchSplinter Review
This turns this off for Fennec and on for apps. That brings us in line with b2g, but if we want, we could also just turn this off on beta/aurora?
Attachment #769766 - Flags: review?(mark.finkle)
Comment on attachment 769766 [details] [diff] [review]
Patch

>diff --git a/mobile/android/app/mobile.js b/mobile/android/app/mobile.js

> // Make <audio> and <video> talk to the AudioChannelService.
>-pref("media.useAudioChannelService", true);
>+pref("media.useAudioChannelService", false);

Tweak the comment a bit? Make it more agnostic to the setting?
Attachment #769766 - Flags: review?(mark.finkle) → review+
Yeah, let turn this off on Aurora and Beta
https://hg.mozilla.org/integration/mozilla-inbound/rev/7e01fb914a16

Will post a new patch for beta and aurora.
Attachment #769858 - Flags: review+
Comment on attachment 769858 [details] [diff] [review]
Patch for beta/aurora

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 809558
User impact if declined: Audio turns off as soon as you switch tabs/apps etc from Fennec.
Testing completed (on m-c, etc.): Landed on mc today
Risk to taking this patch (and alternatives if risky): Very low risk. Pref flip. Pref is not enabled for desktop either.
String or IDL/UUID changes made by this patch: None.
Attachment #769858 - Flags: approval-mozilla-beta?
Attachment #769858 - Flags: approval-mozilla-aurora?
Attachment #769858 - Flags: approval-mozilla-beta?
Attachment #769858 - Flags: approval-mozilla-beta+
Attachment #769858 - Flags: approval-mozilla-aurora?
Attachment #769858 - Flags: approval-mozilla-aurora+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/7e01fb914a16
Assignee: nobody → wjohnston
Status: NEW → RESOLVED
Closed: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
Verified fixed on:
Build: Firefox for Android 25.0a1(2013-07-03) and Firefox for Android 24.0a2(2013-07-03)
Device: LG Nexus 4
OS: Android 4.2.2
Blocks: 890976
Verified fixed on:
Build: Firefox for Android 26.0b6
Device: LG Nexus 4
OS: Android 4.2.2
Status: RESOLVED → VERIFIED
Blocks: 904563
No longer blocks: 904563
You need to log in before you can comment on or make changes to this bug.