High ascii in the attachement are garbled

VERIFIED FIXED in M8

Status

MailNews Core
Internationalization
P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: marina, Assigned: rhp (gone))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Steps to reproduce:
-sent to your acoount several messages from 4.x with attachements on different
lang (french, spanish, german,danish);
-view messages in 5.0;
//note: all high ascii in the attachements are garbage
(observed with 6/25/99 build)
(Reporter)

Comment 1

19 years ago
I have to add some comments to this bug report:  high ascii are garbled in the
body when it was sent In-line ("Send page"). In case i forward the same message
with incorrectly displayed chars to myself they are rendering correctly.

Comment 2

19 years ago
Using 4.5, I send page home.netscape.com/fr to myself. I can view the page with
5.0 (local build updated/build this morning) correctly.
(Reporter)

Comment 3

19 years ago
I looked at the source of pages that have a problem and can add some info : all
problematic pages have in the source this line:"Disposition :inline".Those that
display fine do not mention anything about inline disposition.
(Reporter)

Updated

19 years ago

Comment 4

19 years ago
After looking this over with Marina, the following seems to be
causing this problem.

When the original HTML page was sent as attachment from 4.5, the
MIME option was set to "8-bit as is" and it was HTML mail.

The above URL contains both HTML entities and 8-bit characters,
and it arrives with the following headers:

Charset: iso-8859-1
Content-Transefr encoding: 8-bit

It's this type of msgs we seem to have a problem displaying. I was able
to reproduce the problem under this condition.

As an experiment, I sent 8-bit Latin 1 characters in plain text
mail body and the display was OK.
It then seems that we have a problem with 8-bit characters in HTML
body.

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M8

Comment 5

19 years ago
Accepting, I can reproduce this. Looks like the conversion is done from
ISO-8859-1 to UTF-8 in libmime. Need more investigation.
Adding rhp@netscape.com to cc.

Updated

19 years ago
Assignee: nhotta → rhp
Status: ASSIGNED → NEW

Comment 6

19 years ago
My last comment is incorrect. The conversion I saw was done for the subject
header not for the attachment.
Charset label of multi part is not used for the conversion (main body charset is
used instead) in libmime.
Reassign to Rich.

--------------E29790070C6792C87CB96470
Content-Type: text/html; charset=iso-8859-1;
 name="article.jhtml"
Content-Transfer-Encoding: 8bit
Content-Disposition: inline;
 filename="article.jhtml"
Content-Base: "http://cnn.passagen.se/ekonomi/article
        .jhtml?articleID=556254"
Content-Location: "http://cnn.passagen.se/ekonomi/article
        .jhtml?articleID=556254"

Comment 7

19 years ago
Thanks, Naoki. When I included 8bit characters in the 1st body/8-bit
plain text main and then attached the above URL page, then both
the 1st body part and the attachment body showed 8-bit characters
correctly.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 8

19 years ago
Looking into it...
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

19 years ago
Good catch and thanks for the help! I checked in a fix this afternoon
(Saturday).

- rhp

Updated

19 years ago
QA Contact: momoi → marina

Comment 10

19 years ago
To marina for verification.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 11

19 years ago
** Checked witrh 7/12/99 Win32 build **

(marina is on vacation -- pinch-hitting ...)

I sent the original problem page with 4.7 with no 8-bit characters
in the main body. This created a multi-part message with the
1st part bearing charset=us-ascii and the 2nd part, charset=iso-8859-1.

The above had no problem displaying the accented characters
of the attachment.

Marking the fix verified.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.