Intermittent ld crash while linking xul/gtestxul (collect2: error: ld returned 1 exit status, make[3]: *** [libgtest/libxul.so] Error 1)

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
9 months ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=24770249&tree=Mozilla-Inbound

Linux x86-64 mozilla-inbound build on 2013-06-30 18:59:12 PDT for push 23f0ca9de75f
slave: bld-centos6-hp-016

    INPUT("../../media/webrtc/signaling/signaling_sipcc/src/sipcc/cpr/linux/cpr_linux_stdio.o")
    INPUT("../../media/webrtc/signaling/signaling_sipcc/src/sipcc/cpr/linux/cpr_linux_string.o")
    INPUT("../../media/webrtc/signaling/signaling_sipcc/src/sipcc/cpr/linux/cpr_linux_threads.o")
    INPUT("../../media/webrtc/signaling/signaling_sipcc/src/sipcc/cpr/linux/cpr_linux_timers_using_select.o")

collect2: error: ld returned 1 exit status
make[3]: *** [libgtest/libxul.so] Error 1
make[3]: Target `libs' not remade because of errors.
make[3]: Target `libs' not remade because of errors.
make[3]: Target `libs' not remade because of errors.
make[3]: Leaving directory `/builds/slave/m-in-l64-000000000000000000000/build/obj-firefox/toolkit/library'
make[2]: *** [libgtest/libxul.so] Error 2
make[2]: Target `gtestxul' not remade because of errors.
make[2]: Leaving directory `/builds/slave/m-in-l64-000000000000000000000/build/obj-firefox/toolkit/library'
make[1]: *** [check] Error 2
make[1]: Leaving directory `/builds/slave/m-in-l64-000000000000000000000/build/obj-firefox/testing/gtest'
make: *** [check] Error 2
(Reporter)

Comment 2

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=24984683&tree=Mozilla-Inbound

Can't help but notice that when this happens, it's always while linking WebRTC stuff.
(Reporter)

Updated

6 years ago
Summary: Intermittent ld crash while linking gtestxul (collect2: error: ld returned 1 exit status, [libgtest/libxul.so] Error 1) → Intermittent ld crash while linking gtestxul (collect2: error: ld returned 1 exit status, make[3]: *** [libgtest/libxul.so] Error 1)
Is that the last item in the ld normally?  If so, it's likely not related.

Very little way to attack this issue without reproducability and/or errors from ld
I don't think WebRTC is related. Do we normally have these failure with normal libxul linking? libgtest/libxul.so should be slightly worse because it will link a slightly bigger library but I imagine that we should only see a mirror of libxul linking issues for gtest.
Comment hidden (Treeherder Robot)
Updated title to reflect its not specific to gtest.
Summary: Intermittent ld crash while linking gtestxul (collect2: error: ld returned 1 exit status, make[3]: *** [libgtest/libxul.so] Error 1) → Intermittent ld crash while linking xul/gtestxul (collect2: error: ld returned 1 exit status, make[3]: *** [libgtest/libxul.so] Error 1)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(In reply to TBPL Robot from comment #13)
> Tomcat
> https://tbpl.mozilla.org/php/getParsedLog.php?id=31545850&tree=Mozilla-
> Inbound
> Linux mozilla-inbound build on 2013-12-05 22:45:38
> revision: ca8e76cd1b16
> slave: bld-centos6-hp-008
> 
> PROCESS-CRASH | gtest | application crashed [@ libxul.so + 0x33f479]
> make[1]: *** [check] Error 1
> make: *** [check] Error 2

This looks like a different issue, FYI.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Closing bugs where TBPLbot has previously commented, but have now not been modified for >3 months & do not contain the whiteboard strings for disabled/annotated tests or use the keyword leave-open. Filter on: mass-intermittent-bug-closure-2014-07
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Updated

9 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.