When I reset Firefox the Welcome Back screen doesn't list my previous session

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: verdi, Unassigned)

Tracking

25 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(firefox24 unaffected, firefox25 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 769866 [details]
Empty Welcome Back screen

STR:
1. Open a few tabs
2. Go to about:support and click the Reset Firefox button
3. When the welcome back screen appears the list of tabs to restore will be blank (see attachment)

Expected result:
The welcome back screen should have a list of the tabs I had open before resetting Firefox.

I did find that you could actually restore your session after restarting Fx. STR:
1. Open a few tabs
2. Go to about:support and click the Reset Firefox button
3. When the welcome back screen appears the list of tabs to restore will be blank. Click Clear and you will be taken to about:home.
4. Close and restart Firefox. 
5. When Firefox restarts you will have a restore session button on about:home. Click it and the session from Step 1 will be restored.
status-firefox24: --- → unaffected
status-firefox25: --- → affected
I can't reproduce this on current Nightly. :-(
I guess s/:-(/:-)/, assuming you can't either? :-)
Flags: needinfo?(mverdi)
OTOH, I seem to lose my last tab (with about:support)... not entirely sure why that is.
(Reporter)

Comment 4

5 years ago
Just tested with today's Nightly (7-19) and it works as expected.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(mverdi)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.