Show alternative search engines in autocomplete dropdown

RESOLVED DUPLICATE of bug 1088660

Status

()

Firefox
Search
--
enhancement
RESOLVED DUPLICATE of bug 1088660
4 years ago
2 years ago

People

(Reporter: BenB, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Reproduction:
1. You have "Google" as your primary search engine in the Firefox search field
2. You also have DuckDuckGo, Wikipedia, YouTube and Amazon as search engines installed (OSDs).
3. Type "Statistic" in the search field
4. You want the Wikipedia article (without going via Google)

Actual result:
The autocomplete dropdown lists 10 search suggestions from Google, all going to Google search.
You have to, after typing "Statistic":
5. Click on the v down arrow on the left, right of the Google logo
6. Click on Wikipedia
7. Click on the search icon to start the search
8. Click on the v down arrow on the left, right of the Wikipedia logo
9. Click on Google to reset your primary search engine

Expected result:
When you type "Statistic", you see an autocomplete dropdown.
The dropdown lists
1) the first 3 (not 10) Google search suggestions
2) "Wikipedia search for Statistic", with Wikipedia logo. Same for all other installed search engines (OSDs)
You have to, after typing "Statistic":
1. Press "down" key 4 times
2. Hit enter
You end up directly on Wikipedia.
You did not change your search engine, so you don't have to change it back.

Importance:
This will finally make alternate OSDs actually useful.
We implemented this in bug 1088660. Interesting to see there was already a bug filed for this feature more than a year before we started implementing it.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1088660
You need to log in before you can comment on or make changes to this bug.