Closed Bug 889133 Opened 10 years ago Closed 10 years ago

[Moss] Credit card purchases fail in prod

Categories

(Marketplace Graveyard :: Payments/Refunds, defect)

defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED WONTFIX
2013-07-11

People

(Reporter: krupa.mozbugs, Assigned: keir)

References

Details

Attachments

(3 files)

Attached file logcat
steps to reproduce:
1. Start an in-app purchase for pricepoint 10
2. Enter valid PIN
3. Choose to pay with credit card
4. Enter valid credit card details for Moss
5. Click buy


expected behavior:
Purchase is successful

observed behavior:
Purchase with credit card fails 

adb logcat shows 
07-01 15:51:37.186 E/GeckoConsole(  109): Content JS LOG at https://mozilla.bango.net/_/js/buynow-main.js:5 in anonymous: Invalid reference number System.Data.SqlClient.SqlException (0x80131904): amount not found at cardTransFinish
Attached file headers
Attached image screenshot
Tried with two separate credit cards which Tom unlocked today and was able to reproduce.
Assignee: nobody → keir
Flags: affects-moss+
Example entry point: mozilla.bango.net/mozpayments/?bcid=20109260
FWIW, using a US card I was able to make a purchase successfully
This country mismatch issue is caused by users purchasing from a UK/USA IP address with a spanish CC. This throws an error which is standard and we had discussed previously when doing testing. Only when the IP location and the credit card country match will it complete such as when Kumar tested using USA IP and USA CC.

Recommend this is closed
As Tom comments, when I reproduced this yesterday and today it was due to country mismatch.

I've tried again using my local Credit Card and connecting with the local SIM and the transaction succeeded.
Does this mean that a person who is on roaming cannot purchase apps on their credit card?
If they are roaming on 3G they can purchase on CC because they will be coming through a Moss IP address. But if they are on WIFI they will not be able to purchase becuase it will show as a non-Moss IP address instead.
We need to add this to our FAQ. Closing this as WONTFIX.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
Target Milestone: --- → 2013-07-11
You need to log in before you can comment on or make changes to this bug.