The default bug view has changed. See this FAQ.

Remote debugging doesn't work if any tabs have no title

RESOLVED FIXED in seamonkey2.22

Status

SeaMonkey
Tabbed Browser
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

unspecified
seamonkey2.22

SeaMonkey Tracking Flags

(seamonkey2.19 wontfix, seamonkey2.20 fixed, seamonkey2.21 fixed, seamonkey2.22 fixed)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
If a tab has no title then the debugger server falls back on asking the tabbrowser for the tab's title. However to do this it tries to call the _getTabForContentWindow function. If this does not exist then the debugging session fails. (I don't know whether the browser remains stable.)

Steps to reproduce problem:
1. Enable devtools.debugger.remote-enabled in about:config 
2. Install the debugger server enabler
3. Attempt to connect Firefox

Expected result: List of tabs is displayed

Actual result: Connection hangs
(Assignee)

Comment 1

4 years ago
Created attachment 770166 [details] [diff] [review]
Proposed patch

While I was there I converted two handlers to use the method (which is a neatness improvement on the existing code).
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #770166 - Flags: review?(philip.chee)

Comment 2

4 years ago
Comment on attachment 770166 [details] [diff] [review]
Proposed patch

>            const browsers = this.browsers;
>            if (browsers.length == 1)
>              return;
There is only one use of browsers so you might want to inline it e.g.
if (this.browsers.length == 1)
Attachment #770166 - Flags: review?(philip.chee) → review+

Updated

4 years ago
Blocks: 890348
(Assignee)

Comment 3

4 years ago
Pushed comm-central changeset a6ac2d95f62d.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.22
(Assignee)

Comment 4

4 years ago
Comment on attachment 770166 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 802081
User impact if declined: Can't debug when tabs have empty titles
Risk to taking this patch (and alternatives if risky): Low
String changes made by this patch: None
Attachment #770166 - Flags: approval-comm-beta?
Attachment #770166 - Flags: approval-comm-aurora?
(Assignee)

Updated

4 years ago
status-seamonkey2.19: --- → wontfix
status-seamonkey2.20: --- → affected
status-seamonkey2.21: --- → affected
status-seamonkey2.22: --- → fixed

Updated

4 years ago
Attachment #770166 - Flags: approval-comm-beta?
Attachment #770166 - Flags: approval-comm-beta+
Attachment #770166 - Flags: approval-comm-aurora?
Attachment #770166 - Flags: approval-comm-aurora+
(Assignee)

Comment 5

4 years ago
http://hg.mozilla.org/releases/comm-aurora/rev/8976b7efb6c7
status-seamonkey2.21: affected → fixed
Comment on attachment 770166 [details] [diff] [review]
Proposed patch

Review of attachment 770166 [details] [diff] [review]:
-----------------------------------------------------------------

a-CLOSED_TREE=me
(Assignee)

Comment 7

4 years ago
http://hg.mozilla.org/releases/comm-beta/rev/d4c1227b1eea
status-seamonkey2.20: affected → fixed
You need to log in before you can comment on or make changes to this bug.