Stop choosing arbitrary global object in WebconsoleActor.

RESOLVED DUPLICATE of bug 880511

Status

defect
RESOLVED DUPLICATE of bug 880511
6 years ago
11 months ago

People

(Reporter: ochameau, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

6 years ago
In various experiments (device support, simulators) about connecting tab actors to new targets, I often had to workaround the arbitrary selection of the global scope being done in WebConsoleActor:
http://mxr.mozilla.org/mozilla-central/source/toolkit/devtools/server/actors/webconsole.js?force=1#68
The workaround was to always pass an iframe and never pass a global object.
I think that the parent actor should control the global object the webconsole is going to use. For example:
  this._window = aParentActor.contentWindow;
And even in the case of the global console, I think the parent actor should still control it.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 880511

Updated

11 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.