Closed Bug 889504 Opened 7 years ago Closed 7 years ago

Exception while trying to go to the breakpoint

Categories

(DevTools :: Debugger, defect)

x86_64
Windows 7
defect
Not set

Tracking

(firefox24 verified, firefox25 verified)

RESOLVED FIXED
Firefox 25
Tracking Status
firefox24 --- verified
firefox25 --- verified

People

(Reporter: Optimizer, Assigned: vporof)

Details

Attachments

(1 file)

I am paused (on latest nightly) and then I try to focus the breakpoint line by clicking on the breakpoint in the sources side menu, this exception is thrown:
[00:15:57.061] TypeError: this._selectedBreakpoint.target is null: @chrome://browser/content/devtools/debugger-panes.js:393
@chrome://browser/content/devtools/debugger-panes.js:347
@chrome://browser/content/devtools/debugger-panes.js:606
@chrome://browser/content/devtools/orion.js:156
@chrome://browser/content/devtools/orion.js:4397
@chrome://browser/content/devtools/orion.js:8784
@chrome://browser/content/devtools/orion.js:8329
@chrome://browser/content/devtools/orion.js:8138
@chrome://browser/content/devtools/orion.js:156
@chrome://browser/content/devtools/orion.js:2410
@chrome://browser/content/devtools/orion.js:2559
@chrome://browser/content/devtools/orion.js:8298
@chrome://browser/content/devtools/orion.js:4886
SE_setText@resource:///modules/source-editor-orion.jsm:1616
@chrome://browser/content/devtools/debugger-view.js:460
@chrome://browser/content/devtools/debugger-controller.js:213
EventEmitter_emit@resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/shared/event-emitter.js:107
onRemoteTabNavigated@resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/framework/target.js:350
EV_notify@resource://gre/modules/devtools/dbg-client.jsm:150
@resource://gre/modules/devtools/dbg-client.jsm:642
resolve@resource://gre/modules/commonjs/sdk/core/promise.js:120
then@resource://gre/modules/commonjs/sdk/core/promise.js:45
then@resource://gre/modules/commonjs/sdk/core/promise.js:155
DC_onPacket@resource://gre/modules/devtools/dbg-client.jsm:650
@resource://gre/modules/devtools/dbg-server.jsm -> resource://gre/modules/devtools/server/transport.js:236
@resource://gre/modules/devtools/dbg-server.jsm -> resource://gre/modules/devtools/DevToolsUtils.js:61
 @ resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/shared/event-emitter.js:112

Also, clicking on the breakcrumb has no effect too.
Optimizer, please, I beg you, add STR when you file bugs. This is the n-th bug you file that has none...

I cannot reproduce this Nightly.
(In reply to Victor Porof [:vp] from comment #1)
> Optimizer, please, I beg you, add STR when you file bugs. This is the n-th
> bug you file that has none...

Excuse me, but this is only the second bug like that. Also, those are all the STR's that I have right now. Its not 100% reproducible and right now I cannot reproduce it on the page that I was able to yesterday.

Maybe the error stack will help nail it down ?
Okay I think I got some STR:

1) go to http://htmlpad.org/debugger/
2) Focus line 18 and hit Ctrl + B to set a breakpoint
3) Hit Ctrl + R to reload page
4) Switch to the other script (jquery min)
5) Hit the Click Me button.
6) See browser console.
This may be fixed by bug 886848 because I've accidentally promise everything related to breakpoints.
Attached patch v1Splinter Review
Assignee: nobody → vporof
Status: NEW → ASSIGNED
Attachment #771855 - Flags: review?(past)
(In reply to Victor Porof [:vp] from comment #5)
> Created attachment 771855 [details] [diff] [review]
> v1

When breakpoints were automatically deleted after the tab navigated, the currently _selectedBreakpoint wasn't cleared. Hence the errors. Hence sadness.

This also happens on Aurora, so we'll need to uplift.
Comment on attachment 771855 [details] [diff] [review]
v1

Review of attachment 771855 [details] [diff] [review]:
-----------------------------------------------------------------

Makes sense.
Attachment #771855 - Flags: review?(past) → review+
Thanks!
Whiteboard: [land-in-fx-team]
https://hg.mozilla.org/integration/fx-team/rev/8e392dea63af
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
Comment on attachment 771855 [details] [diff] [review]
v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Highlighting breakpoints in the sources pane would result in type errors after a reload
User impact if declined: Users won't be able to select breakpoints because of the type error
Testing completed (on m-c, etc.): fx-team
Risk to taking this patch (and alternatives if risky): None, this is an almost infinitely small patch
String or IDL/UUID changes made by this patch: None
Attachment #771855 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/8e392dea63af
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 25
Attachment #771855 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(In reply to Girish Sharma [:Optimizer] from comment #3)
> Okay I think I got some STR:
> 
> 1) go to http://htmlpad.org/debugger/
> 2) Focus line 18 and hit Ctrl + B to set a breakpoint
> 3) Hit Ctrl + R to reload page
> 4) Switch to the other script (jquery min)
> 5) Hit the Click Me button.
> 6) See browser console.

Can you confirm this is fixed for you now on the latest nightly or aurora once the patch lands.
(In reply to bhavana bajaj [:bajaj] from comment #12)
> (In reply to Girish Sharma [:Optimizer] from comment #3)
> > Okay I think I got some STR:
> > 
> > 1) go to http://htmlpad.org/debugger/
> > 2) Focus line 18 and hit Ctrl + B to set a breakpoint
> > 3) Hit Ctrl + R to reload page
> > 4) Switch to the other script (jquery min)
> > 5) Hit the Click Me button.
> > 6) See browser console.
> 
> Can you confirm this is fixed for you now on the latest nightly or aurora
> once the patch lands.

Its fixed on today's Nightly.
Verified fixed on Fx 24 beta 9, buildID 20130905180733.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
QA Contact: petruta.rasa
Verified fixed on Fx 25.0a2, buildID 20130910004002.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.