Last Comment Bug 889617 - Provide API for user requested language fallback
: Provide API for user requested language fallback
Status: RESOLVED DUPLICATE of bug 889335
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: general
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 15:17 PDT by Zibi Braniecki [:gandalf][:zibi]
Modified: 2013-07-02 15:21 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Zibi Braniecki [:gandalf][:zibi] 2013-07-02 15:17:42 PDT
We currently only expose primary language preference from the user via navigator.language.

In reality, we always want to allow user to build a fallback list of languages to use in case the primary one is missing.

We need an API that exposes that langauge fallback list for the apps to use.
Comment 1 Boris Zbarsky [:bz] 2013-07-02 15:18:28 PDT
Is this a duplicate of bug 889335?
Comment 2 Zibi Braniecki [:gandalf][:zibi] 2013-07-02 15:21:58 PDT
I think it is.

*** This bug has been marked as a duplicate of bug 889335 ***

Note You need to log in before you can comment on or make changes to this bug.