[sms] sometimes the SMS is truncated before sent

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::SMS
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: julienw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
I got that twice in 3 months, so it's quite rare. But when this happens, this is frustrating, and this is a dataloss, because we can't get the missing part back.

I don't have a STR other that: write a multi-sentences SMS and send it.

When the bug happens, the SMS is truncated, and is sent as is. The displayed mesage is the truncated message. The 2 times it happened, it was truncated just after a period, that is, after a sentence, but I don't know if that's a coincidence or part of the bug.

I'm asking leo+ here, mostly because of the dataloss, but because it's so rare, I could understand if triagers decide otherwise.
Do you have the messages that you sent and those that were received?

It's tough to block on something like this without an STR and with such a rare reproduction rate.  Triagers agree that dataloss is unacceptable.  Triage decision is that we won't block here and hope that someone else will run into this with more information allowing someone to track down the root cause.
blocking-b2g: leo? → ---
(Reporter)

Comment 2

5 years ago
I know the message that I sent and that were received is the one that is displayed, sorry for not mentioning this earlier.

I don't have the actual message that I _tried_ to send. I should probably add some log in the sms app in the case this happens again.
(Reporter)

Comment 3

4 years ago
I haven't seen this for a long time.

Might be the same than bug 939971.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.