Closed Bug 889970 Opened 11 years ago Closed 11 years ago

Defect - Selection expands automagically in the urlbar after a drag + tap

Categories

(Firefox for Metro Graveyard :: Input, defect, P2)

x86_64
Windows 8.1
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jimm, Assigned: jimm)

References

Details

(Whiteboard: [selection][shovel-ready] feature=defect c=tbd u=tbd p=1)

Attachments

(2 files, 1 obsolete file)

str:

1) visit a site
2) tap the urlbar text a few times to get a single selection monocle at the caret position.
3) drag the monocle to the left to select, all the way off the urlbar edit
4) tap on the right side of the domain

result: text selection starts advancing from the caret position

expected: you should get a single caret monocle on the right side of the text
Attached patch fix (obsolete) — Splinter Review
Missing bit in the chrome selection handler. Clear any auto scroll timers on drag end.
Assignee: nobody → jmathies
Attached patch fixSplinter Review
Tim, mind taking a simple selection review?
Attachment #771759 - Attachment is obsolete: true
Attachment #771760 - Flags: review?(tabraldes)
Blocks: metrov1it10
No longer blocks: metrov1triage
Status: NEW → ASSIGNED
Priority: -- → P2
QA Contact: jbecerra
Summary: Selection expands automagically in the urlbar after a drag + tap → Defect - Selection expands automagically in the urlbar after a drag + tap
Whiteboard: [selection][shovel-ready] → [selection][shovel-ready] feature=defect c=tbd u=tbd p=1
Comment on attachment 771760 [details] [diff] [review]
fix

Review of attachment 771760 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #771760 - Flags: review?(tabraldes) → review+
https://hg.mozilla.org/mozilla-central/rev/1a0ab7c93236
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Went through the following "Defect" for iteration #10 with some issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-07-16-03-02-02-mozilla-central/

Went through the following test cases without any issues:

- Reproduced the original issue by installing an older build
- Went through the original test case in comment 0
- Selecting text using the single monocle left to right & right to left then tapping at the end of the URL
- Selecting text and then tapping at the end of the URL while there are two monocles being displayed with selected text
- Test in both "Full" and "Filled" views

Possible issues:

When going through this defect, I ran into a few OSK issues and monocles being left behind when the OSK & App bar was being dismissed. Noticed that sometimes there will be three monocles, once you move the third one the other two disappear. Not really sure if this is intended behavior but it doesn't really feel intuitive (its also in older builds). Jim, are the three monocles expected behavior? (attached a screenshot of the three monocles)
Flags: needinfo?(jmathies)
> When going through this defect, I ran into a few OSK issues and monocles
> being left behind when the OSK & App bar was being dismissed. Noticed that
> sometimes there will be three monocles, once you move the third one the
> other two disappear. Not really sure if this is intended behavior but it
> doesn't really feel intuitive (its also in older builds). Jim, are the three
> monocles expected behavior? (attached a screenshot of the three monocles)

Sounds like two fresh bugs that should be filed.
Flags: needinfo?(jmathies)
Thanks Jim, will create the appropriate bugs and attach them to their corresponding stories
User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130806104538
Built from http://hg.mozilla.org/mozilla-central/rev/1e381c91885d

WFM
Tested on windows 8 using latest nightly. 
Followed steps given in comment0 and I got a single caret monocle on the right side of the text.
Went through the following "Defect" for iteration #12 without any issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-08-15-03-02-03-mozilla-central/

- Went through the original test case in comment #0 without any issues
- Went through the test cases added in comment #5 without any issues
- Also went through all of the above test cases in Filled View without any issues
Went through the following "Defect" for iteration #13 without any issues. Used the following build:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-09-09-03-02-04-mozilla-central/

- Went through the original test case added in comment #0 without any issues
- Went through the test cases added in comment #5 without any issues
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: