Browser needs an "Up" navigation button



UI Design
17 years ago
9 years ago


(Reporter: Johan Walles, Unassigned)


Dependency tree / graph

Firefox Tracking Flags

(Not tracked)


(Whiteboard: parity-konqueror)



17 years ago
The browser currently has two navigational buttons; forwards and back.  I would
like to see an additional button for "up".  Up would work like this:

Let's say I'm at "". 
Pressing up a couple of times should take me through the following URLs:

Also, as an additional feature, if the first word of an http URL is not "www",
as a last step it could be replaced by "www".  For example, pressing up at should take me to  If the
http URL is only two words, the replacement should not take place however (up at
"" should not go to "").

Comment 1

17 years ago
Probably dup of bug 87428 i.e. bug 2800

Comment 2

17 years ago
Nope.  Those bugs deal with the HTML "LINK" element.  This bug doesn't deal with
HTML at all, this is pure string mangling.
This is very easy to achieve manually by adding the following bookmark to the
Personal Toolbar Folder:


Comment 4

17 years ago
Cool!  That works quite OK.

You don't happen to know how to get a button doing that into the Modern theme?

BTW: My (personal) point with this bug is:
1. Getting it working for myself.
2. Getting it working for other people.
Point one has obviously just been mostly solved (thanks Simon!) (although the
solution won't (in its current state) convert into as per the original feature request).

Point two to go.

Since you like my suggestion, I should give credit to Steve Kangas and

Adding your second feature is probably not a big deal for anyone who knows a bit
more Javascript than I do :-)
This seems like something that would be more worthwhile as a bookmarklet than a
permanent chrome button...  mpt?
Ever confirmed: true


17 years ago
Summary: Browser needs an "Up" button → [RFE] Browser needs an "Up" button

Comment 7

17 years ago
Unfortunately, this was marked WONTFIX in bug 33684 which suggested exactly the
same things. The bookmarklet is a great idea, and I've noted it in that bug. If
someone wants to reopen the bug (as an RFE) and assign it to
I can do that for you.

Marking as dup (but i'd love this feature too)

*** This bug has been marked as a duplicate of 33684 ***
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified duplicate

Comment 9

17 years ago
FWIW, if there are no bugs open to make the following set of steps work, someone
should file them:

    PC                 Mac
1.  Control+L          Command+L
2.  Right arrow        Right arrow
3.  Control+Backspace  Option+Backspace
4.  Enter              Enter

Step 3 wouldn't do *exactly* what you want here -- it would delete to the
previous boundary between alphanumeric and non-alphanumeric characters that was
more than one character away, and that boundary wouldn't always be a `/'
character. But it would make going to the next highest level a lot easier than
it is now.

Comment 10

17 years ago
Reopening from being a dup of bug 33684.  Toolbars aren't customizable yet (bug 
15144), so bug 33684 is going to add a menu item without adding a button.

mpt: see bug 98546... and I can't get ctrl+backspace to work at all (Win98).
Depends on: 15144, 33684
Resolution: DUPLICATE → ---

Comment 11

17 years ago
Another workaround until this is implemented in Mozilla proper is available at
"".  That gives you support for gestures, of
which one means "up".  Just like the javascript workaround (see above) it
doesn't do everything, but it is another option.


17 years ago
Summary: [RFE] Browser needs an "Up" button → [RFE] Browser needs an "Up" navigation button

Comment 12

17 years ago
This appears to have a spec, please move to the appropreate component 
and reassign to default owners to get this fixed.

Comment 13

17 years ago
From bug 33684 comment 64 (jmd): the Up button could be a dual menubutton (like 
the forward and back buttons), with the dropdown containing items for going up 
several levels:

Clicking the up button twice quickly should have the same effect as selecting 
the second item in the dropdown.

Comment 14

17 years ago
See also bug 110014, "Extend functionality up/top on site navigation toolbar".  
I'd like to be able to have this button on my navigation toolbar because I 
don't keep the site navigation toolbar visible, but that will have to wait for 
bug 15144 (customizable toolbars).

Comment 15

16 years ago
*** Bug 124331 has been marked as a duplicate of this bug. ***
*** Bug 110014 has been marked as a duplicate of this bug. ***


16 years ago
Blocks: 157199


16 years ago
No longer blocks: 157199

Comment 17

16 years ago
*** Bug 164446 has been marked as a duplicate of this bug. ***

Comment 18

16 years ago

I like the javascript method to get an up button (why isn't this documented
somewhere so people don't have to search to find it?).  However, just as I got a
Home button from, I would really
like an Up button that isn't on my personal toolbar.  It seems to me that the
people at (Diggler add-on) are very close
to having an Up button implemented, even though that is not what they intend
exactly.  I already filed a bug at Diggler asking if I could just have an Up
button, but I got no response.  I'll email the guy who made the home button now.
 Maybe everyone can coordinate on this one???

Comment 19

16 years ago
Assignee: mpt → blaker
Component: User Interface Design → XP Apps: GUI Features
QA Contact: zach → paw
Summary: [RFE] Browser needs an "Up" navigation button → Browser needs an "Up" navigation button

Comment 20

15 years ago
Carefully analyzing why i find browsing with IE more comfortable than with
Mozilla i came to this missing "Up" button which is present in IE's Google bar

Comment 21

15 years ago
Thanks for the input Stefan. You should consider using Simon Montagu's
bookmarklet, or installing the GoUp extention for Firebird which:
  "Allows you to quickly move up a level in a site by pressing Alt + Up"

This will probably never be fixed in base Mozilla or Firebird (for the fairly
valid reasons mentioned in bug 33684) so I suggest it be marked WONTFIX to get
it over with.

Additionally, it would be spiffy is someone made a new toolbar button extention,
that implemented Jesse and my idea in comment 13.

Comment 22

14 years ago
Reassigning obsolete bugs to their respective Seamonkey owners (i.e. nobody). 
If you want this fixed for Firefox, change the Product and Component accordingly
and reassign back to me.
Assignee: firefox → guifeatures
Product: Core → Mozilla Application Suite
No comment in 4 years -- resetting A+QA.

Konqueror 3.5.7 has this feature; Firefox can be equipped with it (the Go Up extension); but I'm not convinced it belongs in the basic featureset, especially now that Sm2 has a "decent" add-ons manager.
Assignee: guifeatures → nobody
Depends on: 394288
QA Contact: pawyskoczka → guifeatures
Whiteboard: parity-konqueror

Comment 24

10 years ago
The Up feature is just as basic as the URL bar and the Back/Forward buttons. But maybe they are being made add-ons as well eventually?

A really good thing with Konqueror is that it has many basic features included; all navigation buttons, MNG rendering, adblock, cookie control. I do not know why Mozilla is so crazy about putting almost everything in a plugin. I do not even know how all those plugins should be installed system-wide. At least Gentoo does not seem to have packages for them. So now each user has to install and maintain a set of software in his home directory. That waste disk space as well as maintenance burden.

Comment 25

10 years ago
I thought the feature already existed (alt + up arrow, in the "Go" menu), it just needs a toolbar graphic and binding.

Comment 26

10 years ago
We won't create such a button directly in SeaMonkey - I was involved in numerous discussions that always came out with an "up" function being useless or bad on websites (unless defined by the web page itself, see the Site Navigation Bar).
This is a perfect fit for a function that should be provided by an extension.

Konqueror needs this because it is another ill-fated attempt on being a file manager and browser all in one window, and I'm not sure this function will stay at all when it gets transformed to being a real web browser in KDE4, where Dolphin is split out as the file manager.

esgira, from what you are telling here, maybe Konqueror is actually the product you want? We have a powerful add-on architecture, esp. with SeaMonkey 2, and we intend to use it.
Adding stuff to the UI that most users don't need is not the way to go in our defaults.

Please ONLY reopen this is you are among the core developer group of SeaMonkey and disagree with me.
Last Resolved: 17 years ago10 years ago
Resolution: --- → WONTFIX


10 years ago
Component: XP Apps: GUI Features → UI Design


9 years ago
No longer depends on: 15144
You need to log in before you can comment on or make changes to this bug.