Closed Bug 890155 Opened 7 years ago Closed 7 years ago

[MMS] Not possible to save the image received from the Nexus4 device

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect, P1)

ARM
Gonk (Firefox OS)

Tracking

(blocking-b2g:leo+)

RESOLVED DUPLICATE of bug 890453
1.1 QE4 (15jul)
blocking-b2g leo+

People

(Reporter: leo.bugzilla.gaia, Assigned: steveck)

Details

(Whiteboard: [TD-55987], [u=commsapps-user c=messaging p=0], TaipeiMMS)

Attachments

(1 file)

1. Title: Not possible to save the image received from the Nexus4 device
2. Precondition: Sending and receiving MMS should be possible
3. Tester's Action: 1) From Nexus 4 send MMS with one picture to the FFOS device
                2) Recive it on FFOS and open the picture content, try to save it 
4. Detailed Symptom (ENG.) : The picture is not saved in the gallery
5. Expected: The picture should be saved in the Gallery
6. Reproducibility: Y
1) Frequency Rate : 100%
7. Gaia Master/v1-train: Reproduced on v1-train
8. Gaia Revision: f2d6ed54a236e6e3b94f0abad9f0dacb8a1cc7b3
9. Personal email id: sasikala.paruchuri8@gmail.com
blocking-b2g: --- → leo+
Whiteboard: [TD-55987]
Target Milestone: --- → 1.1 QE4 (15jul)
Could you provide some log while saving the images? Thanks.
Attached file Logcat logs attached
Hi Steve,
Please check the log cat logs attached for the defect.
Thanks
Whiteboard: [TD-55987] → [TD-55987], [u=commsapps-user c=messaging p=0]
Priority: -- → P1
Steve - Leo suggests that this may be due to files received from Nexus 4 do not have a file extension.

Leo: It also occurs when sending a MMS from FFOS to FFOS with cropping.
Flags: needinfo?(schung)
Hi Wayne, I don't have a Nexus 4 for testing, but saving a file without extension might cause some problem. I'm not sure it's the same root cause, but I'll take some time to investigate the problem in saving a cropped image from FFOS.

Leo: I could not discover any helpful information from the log. But I did found some error while saving the cropped image (TypeMismatchError). Please open the dedug log in settings (device information -> more information -> developer. tick remote debugging & console log) and adb logcat -c to clear all the log before click the save button.
Flags: needinfo?(schung)
Assignee: nobody → schung
I could not find a Nexus4 with stock rom now. I've tried cyanogenmod but it works fine. Could you please check the title of image opened in gallery app? If the title is "untitled" or file name without extension, it would be the same root cause when saving the cropped image. Otherwise it might belong to other unknown issue.
Flags: needinfo?(leo.bugzilla.gaia)
Whiteboard: [TD-55987], [u=commsapps-user c=messaging p=0] → [TD-55987], [u=commsapps-user c=messaging p=0], TaipeiMMS
If you save the files to getDeviceStorage('pictures') then it has to have the correct extension.

If you save the files to getDeviceStorage('sdcard') then it can have any extension.

I believe that gallery will only show the image files which have the correct extensions (so this may influence which storage type to use).
This issue is same as Bug 890453
Fix for 890453 solved this issue also.

Root cause, as mentioned in Bug 890453 and in comment #5, is that the received image didnt had any extension.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(leo.bugzilla.gaia)
Resolution: --- → DUPLICATE
Duplicate of bug: 890453
You need to log in before you can comment on or make changes to this bug.