Remove nsIIDBVersionChangeEvent

RESOLVED FIXED in mozilla25

Status

()

Core
DOM: IndexedDB
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Ehsan, Assigned: Ehsan)

Tracking

(Blocks: 1 bug)

Trunk
mozilla25
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

Comment hidden (empty)
(Assignee)

Comment 1

5 years ago
Created attachment 771504 [details] [diff] [review]
Patch (v1)
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Attachment #771504 - Flags: review?(Jan.Varga)

Comment 2

5 years ago
Comment on attachment 771504 [details] [diff] [review]
Patch (v1)

Review of attachment 771504 [details] [diff] [review]:
-----------------------------------------------------------------

::: addon-sdk/source/lib/sdk/indexed-db.js
@@ -55,5 @@
>  exports.DOMException = Ci.nsIDOMDOMException;
>  exports.IDBCursor = Ci.nsIIDBCursor;
>  exports.IDBTransaction = Ci.nsIIDBTransaction;
>  exports.IDBOpenDBRequest = Ci.nsIIDBOpenDBRequest;
> -exports.IDBVersionChangeEvent = Ci.nsIIDBVersionChangeEvent;

IIRC you should inform someone from JetPack team about this change

::: dom/indexedDB/IDBEvents.cpp
@@ +19,1 @@
>  

Nit: I would move this above the usings with an empty line between them

::: dom/indexedDB/IDBEvents.h
@@ +40,5 @@
>  CreateGenericEvent(mozilla::dom::EventTarget* aOwner,
>                     const nsAString& aType,
>                     Bubbles aBubbles,
>                     Cancelable aCancelable);
>  

Nit: I would move this after |#define UPGRADENEEDED_EVT_STR "upgradeneeded"| with an empty line between them
Attachment #771504 - Flags: review?(Jan.Varga) → review+
(Assignee)

Comment 3

5 years ago
Comment on attachment 771504 [details] [diff] [review]
Patch (v1)

Review of attachment 771504 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/indexedDB/IDBEvents.cpp
@@ +19,1 @@
>  

OK, but that requires explicitly prefixing IDBVersionChangeEvent with its namespace prefix.
(Assignee)

Comment 4

5 years ago
Created attachment 771659 [details] [diff] [review]
Patch (v2)

Over to Mossop for the add-on SDK change (a 1 line change, FWIW.)
Attachment #771504 - Attachment is obsolete: true
Attachment #771659 - Flags: review?(dtownsend+bugmail)

Comment 5

5 years ago
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #3)
> Comment on attachment 771504 [details] [diff] [review]
> Patch (v1)
> 
> Review of attachment 771504 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: dom/indexedDB/IDBEvents.cpp
> @@ +19,1 @@
> >  
> 
> OK, but that requires explicitly prefixing IDBVersionChangeEvent with its
> namespace prefix.

oh, then leave it as it is
but an extra empty line would be awesmome :)
(Assignee)

Comment 6

5 years ago
Created attachment 771682 [details] [diff] [review]
Patch (v2)
Attachment #771659 - Attachment is obsolete: true
Attachment #771659 - Flags: review?(dtownsend+bugmail)
Attachment #771682 - Flags: review?(dtownsend+bugmail)
Attachment #771682 - Flags: review?(dtownsend+bugmail) → review+

Updated

5 years ago
Blocks: 892571
(Assignee)

Comment 8

5 years ago
Backed out because of test failures
(Assignee)

Comment 9

5 years ago
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #8)
> Backed out because of test failures

(https://hg.mozilla.org/integration/mozilla-inbound/rev/7ba9864d7a9e)
(Assignee)

Updated

5 years ago
Duplicate of this bug: 892571

Comment 12

5 years ago
Commit pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/0e9c10e9889aacc34cf77bd08f0e4fc426c5e9ed
Uplift Bug 890405 - Remove nsIIDBVersionChangeEvent to Add-on SDK. r=janv,mossop
https://hg.mozilla.org/mozilla-central/rev/108049fedd49
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
(In reply to Ed Morley [:edmorley UTC+1] from comment #14)
> https://hg.mozilla.org/mozilla-central/rev/e97532f5fd86

Empty patch
(In reply to :Ms2ger from comment #15)
> (In reply to Ed Morley [:edmorley UTC+1] from comment #14)
> > https://hg.mozilla.org/mozilla-central/rev/e97532f5fd86
> 
> Empty patch

Yeah, apparently my original uplift of SDK code didn't blow away this bug's change like I thought it did. So an empty patch is the "correct", but unnecessary thing...
You need to log in before you can comment on or make changes to this bug.