If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Submenus don't change when moving mouse over next label

RESOLVED WORKSFORME

Status

()

Core
XUL
RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: Me!, Assigned: David Hyatt)

Tracking

Trunk
mozilla1.0.1
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010703
BuildID:    00000000000000000000000

If I move the mouse pointer over a label in any menu and the submenu appears
(late) and I then move the pointer over the next label the submenu closes but
the new submenu does not popup. I first have to move the pointer a bit.

Reproducible: Always
Steps to Reproduce:
1.click on label "view"
2.move pointer over "text size"
3.wait for the submenu popping up
4.move the pointer down over "Use Stylesheet"
5.wait
6.See how the submenu closes
7.See how the label "Use Stylesheet" gets highlighted
8.See how highlightning disappears
9.Wait for submenu popping up
10.give up waiting

if one keeps a submenu open for a longer while, it works sometimes

Expected Results:  Mozilla opens the new submenu that pointer points at

Comment 1

17 years ago
Looks like a duplicate of bug #74059.
Over to XP Menus.

I am reluctant to mark this as a dup of Bug 41766 because IMO Bug 74059 should
not have been marked as a dup of bug 41766.  I see the behaviour in 41766 but
not in 74059 or this one.  I do think however that Bug 74059 is the same as this.

Dennis, do you still see this on newer nightlies from
http://ftp.mozilla.org/pub/mozilla/nightly/latest/ ?
Assignee: joki → pinkerton
Status: UNCONFIRMED → NEW
Component: Event Handling → XP Toolkit/Widgets: Menus
Ever confirmed: true
QA Contact: madhur → jrgm
(Reporter)

Comment 3

17 years ago
Yes, I do. Because the layer blinks in blue one time and then the prog seems to
work a bit and then stops  it may be a timing problem?

Comment 4

17 years ago
This is the same basic series of steps as bug 41766, and most likely a dupe, but
because that one doesn't deal with two submenus maybe we should keep it open for
verification once bug 41766 gets resolved.  Marking dependent, though.
Depends on: 41766

Updated

17 years ago
No longer depends on: 41766
Target Milestone: --- → mozilla1.0

Comment 5

16 years ago
Whoops, didn't mean to clear the dependency four minutes after I set it.
Depends on: 41766

Comment 6

16 years ago
My 2001-07-20 11:26 comment on the dependant bug mentions the "two submenus"
instance, specifically, for bookmarks (which is even more annoying them some
uncommonly used program pulldowns.

Note this is targeted for 1.0 and 41766 is 1.1
new owner
Assignee: pinkerton → hyatt
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: mozilla1.0 → mozilla1.0.1

Updated

9 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets

Comment 8

9 years ago
This WFM now in a current build. Probably fixed by bug 41766 and/or bug 74059.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.