Caret does not move sometimes when changed programatically

RESOLVED WONTFIX

Status

()

Firefox for Android
Keyboards and IME
RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: maxli, Assigned: jchen)

Tracking

({reproducible, testcase})

Trunk
All
Android
reproducible, testcase
Points:
---

Firefox Tracking Flags

(fennec-)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 771522 [details]
Testcase

STR:
0. Open attached testcase.
1. Click in the top left corner (which is a contenteditable).
2. Type some stuff.
3. Wait for the caret to move back a word (this happens 8 seconds after the page loads). Notice that the caret moves visually.
4. Type something. What is typed is appended to the end of the text, not where the caret was displayed.

Note that this does not happen if after you type, you move focus off the editable and move it back on before the caret changes.

Updated

5 years ago
Keywords: reproducible, testcase

Updated

5 years ago
tracking-fennec: --- → ?
(Assignee)

Updated

5 years ago
Assignee: nobody → nchen
Component: Text Selection → Keyboards and IME
tracking-fennec: ? → -
(Assignee)

Comment 1

5 years ago
Looks like it's a bug in the stock keyboard. AFAICT, we do make the correct API call, and SwiftKey doesn't have this problem. Marking as WONTFIX for now.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.