jumpy scrolling on vimeo & delay in opening page info

NEW
Unassigned

Status

()

Firefox
General
4 years ago
10 months ago

People

(Reporter: Stefan, Unassigned)

Tracking

(Blocks: 1 bug)

17 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [platform-rel-Vimeo])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
User Agent: 

Steps to reproduce:

1. Open https://vimeo.com/
2. Scroll vertically


Actual results:

2. jumpy scrolling


Expected results:

2. smooth scrolling

(ESR 17.0.6 Linux)
(Reporter)

Updated

4 years ago
OS: Other → Linux
Hardware: Other → x86_64
QA Contact: sudheesh1995
can you provide a screenshot of your about: page, i am having a slight doubt about the firefox version. I couldn't reproduce the bug on v17.

> Type in about: in the URL bar.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(kdevel)
(Reporter)

Comment 2

4 years ago
Created attachment 771679 [details]
screenshot of the about:-page. Version 17.0.6 ESR
Flags: needinfo?(kdevel)
A little more info would clear this. This looks similar to bug 530946 but here are a few questions worth considering.

[1] What was the format of the video ? Was it a .webm ?
[2] Are you by chance using 720p instead of the default 360p setting?
[3] Can you please paste the graphics section of about:support into the bug?
[4] How does it work out in Full Screen ?
Flags: needinfo?(kdevel)
Component: Untriaged → Video/Audio
Product: Firefox → Core
Whiteboard: 571386, 530946
Version: 17 Branch → Trunk

Comment 4

4 years ago
Is it the scrolling of the web page that's the issue? Not the video playback?
Looks like i've misunderstood the bug, there have been reports of skipping frames too. Sorry for the confusion.
Component: Video/Audio → General
Product: Core → Extend Firefox
Version: Trunk → unspecified
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Whiteboard: 571386, 530946
Duplicate of bug: 681072
Blocks: 100951
(Reporter)

Comment 7

4 years ago
(In reply to Chris Double (:doublec) from comment #4)
> Is it the scrolling of the web page that's the issue? Not the video playback?

It is - as I have written - the scrolling of the vimeo start page 
http://vimeo.com/ which is jumpy, this bug is not about video playback. The jumpiness is there and it is on the start page where no video is selected for playback.

(In reply to Sudheesh Singanamalla (:ShellHacker) from comment #5)
> Looks like i've misunderstood the bug,

Right.

> there have been reports of skipping
> frames too. Sorry for the confusion.

This bug is not about skipping frames in video but about a scrolling issue on the vimeo start page.
Status: RESOLVED → REOPENED
Flags: needinfo?(kdevel)
Resolution: DUPLICATE → ---
(Reporter)

Comment 8

4 years ago
Some more information. I have reproduced the issue using this binary
http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/17.0.7esr/linux-i686/en-US/
on a different machine running on Knoppix 7.0.5 (started from USB stick).

To clarify what I mean with "jumpy": Press and hold the mouse button over the vertical slider. Now slowly but steadily move the mouse down. On the machines here it stands out that the mouse pointer advances but frequently the slider stops and after some moment it jumps to the current position of the mouse pointer.

You may also observe that after the vimeo-Page has been loaded all dialog windows (e.g. Ctrl-I or help/About Firefox) show a significant delay before their contents are displayed.
[1] Is there a specific hash in the URL of the video, I am noticing firefox jumping to anchors but still unable to reproduce the issue by slowly dragging the vertical scroll bar to result in a jerky motion.

[2] Is it only for vimeo or is it for any website ? specifically video websites only ?

It could be more of a website issue.

>You may also observe that after the vimeo-Page has been loaded all dialog windows e.g. >Ctrl-I or help/About Firefox) show a significant delay before their contents are >displayed.

Couldn't see a dramatic change in this either. Please provide the hardware specifications too?
Status: REOPENED → UNCONFIRMED
Ever confirmed: false
Flags: needinfo?(kdevel)
(Reporter)

Comment 10

4 years ago
(In reply to Sudheesh Singanamalla (:ShellHacker) from comment #9)
> [1] Is there a specific hash in the URL

No, http://vimeo.com does contain no hash at all.

> of the video,

This bug report's issue is *not* the issue of a video but that of web page (http://vimeo.com) which firefox is unable to scroll smoothly.

> I am noticing firefox jumping to anchors 

Are we talking about the same page, http://vimeo.com?

> but still unable to reproduce the issue by slowly
> dragging the vertical scroll bar to result in a jerky motion.

Does your mouse pointer stay fully aligned to the slider's position where you initially pressed the mouse button when you scroll?

> [2] Is it only for vimeo or is it for any website ? 
> specifically video websites only ?

I am not aware of other websites.

> It could be more of a website issue.

Well it's more like being pregnant and I do not think that the website is.

> >You may also observe that after the vimeo-Page has been loaded all dialog windows e.g. >Ctrl-I or help/About Firefox) show a significant delay before their contents are >displayed.
> 
> Couldn't see a dramatic change in this either.

Is this a confirmation that you actually *do* see a change?

> Please provide the hardware
> specifications too?

This is three year old dual-core 64-Bit intel cpus both with 4 GiB RAM. One has AMD the other NVIDIA graphics.
Flags: needinfo?(kdevel)
>Does your mouse pointer stay fully aligned to the slider's position 
>where you initially pressed the mouse button when you scroll?

Yes, It works fine on the homepage. I've tried opening random videos and checking what happens to the vertical bar when dragging it. Couldn't still replicate the same issue.

>I am not aware of other websites.

Another website with a similar layout to Vimeo's homepage is Intel's Perceptual Computing challenge. https://perceptualchallenge.intel.com/ Yes i can now confirm the jumping of the vertical scroll bar, but I guess on this website its more of a feature than a bug to Firefox. 

Getting back to Vimeo

>Is this a confirmation that you actually *do* see a change?
>This is three year old dual-core 64-Bit intel cpus both with 4 GiB RAM. 
>One has AMD the other NVIDIA graphics.

I noticed a change -> [YES]
That could be because of the file I was streaming. Very very negligible difference. Just a matter of different time taken.

vimeo is a centrally aligned site with a scroll bar present in its CSS file, which says

html{
	color:#7b8084;
	background:#fff;
	overflow-y:scroll
}

[1] overflow-y:scroll is not ended with a semicolon. Tiny css problem but wait it shouldn't cause a jump. So I kind of ruled it out.

[2] Did you enable smooth scrolling?
[3] Did you disable the session saver? That's usually the thing that causes pauses. Not sure if it remembers scroll position, but if so, then that's why.
[4] Any other smooth scroller addons ? Have you tried safe mode with all addons disabled?

>This is three year old dual-core 64-Bit intel cpus both with 4 GiB RAM. One has AMD the other NVIDIA graphics.

Awesome!
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(kdevel)
Created attachment 771772 [details]
CSS used on vimeo.com
(Reporter)

Comment 13

4 years ago
(In reply to Sudheesh Singanamalla (:ShellHacker) from comment #11)
> >Does your mouse pointer stay fully aligned to the slider's position 
> >where you initially pressed the mouse button when you scroll?
> 
> Yes, It works fine on the homepage.

So you can't confirm it. Are you even running Linux?

> >Is this a confirmation that you actually *do* see a change?
> I noticed a change -> [YES]

So you confirm the second observation related to vimeo.

> [2] Did you enable smooth scrolling?

The issue does not depened on the setting of smooth scrolling.

> [3] Did you disable the session saver? 

I did not disable anything.

> [4] Any other smooth scroller addons ? Have you tried safe mode with all
> addons disabled?

There are no extensions plugins installed. The issue just happens with the firefox from the tarball and with any empty profile.
Flags: needinfo?(kdevel)
>So you can't confirm it. Are you even running Linux?

I am unable to confirm it. Let me give it another shot. Yes I am running Linux Ubuntu 13.04

>So you confirm the second observation related to vimeo.
[1] Yes, the bookmarks bar initially came up after a slight delay but on repeated pressing of Ctrl + I, the opening and closing feel normal.

[2] Closing the browser and re-starting and pressing Ctrl + I ,doesn't result in the same problem.

[3] It looks like it only happens the first time after every restart of the machine, but well ... I am shifting the location of the bug.

Lets see where it goes.
Component: General → General
Product: Extend Firefox → Firefox
Version: unspecified → 17 Branch
(Reporter)

Comment 15

4 years ago
(In reply to Sudheesh Singanamalla (:ShellHacker) from comment #14)
> >So you confirm the second observation related to vimeo.
> [1] Yes, the bookmarks bar initially came up

Are we talking about Firefox 17.0.6 or 17.0.7esr version? Do you use the binary
http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/17.0.7esr/linux-i686/en-US/?

When I press ctrl-i no "bookmarks bar" comes up. ctrl-i open the Page Info dialog window on my machine.

> [2] Closing the browser and re-starting and pressing Ctrl + I ,doesn't
> result in the same problem.

What graphics card are you using? What CPU/mode? What window manager?

> Lets see where it goes.

If you don't give it a direction it will walk in circles.
I've done a reinstall. Previous one was not installed properly. I was working it from source. 

Yes reconfirming Ctrl + I opens up Page Info. Yes there is a delay. 

I still am unable to reproduce the jerky scrolling.

>What window manager?

KDE

    XDG_CURRENT_DESKTOP=
    GDMSESSION=kde-plasma

Unity 3d

    XDG_CURRENT_DESKTOP=Unity
    GDMSESSION=ubuntu

Unity 2d

    XDG_CURRENT_DESKTOP=Unity
    GDMSESSION=ubuntu-2d

>Graphics card
Nvidia GeForce GT230M

>If you don't give it a direction it will walk in circles.
I've put it into General Firefox , 17 branch. Someone else who can reproduce this can work on it.
Summary: jumpy scrolling on vimeo → jumpy scrolling on vimeo & delay in opening page info
platform-rel: --- → ?
Whiteboard: [platform-rel-Vimeo]
platform-rel: ? → ---
You need to log in before you can comment on or make changes to this bug.