network.auth.force-generic-ntlm set to true by default

RESOLVED WONTFIX

Status

()

Firefox
Build Config
RESOLVED WONTFIX
5 years ago
4 years ago

People

(Reporter: Yunier J., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

Some users of Cuba have problems with it configuration and sometimes Firefox ask many passwords for surf on the web. In Cuba, many places use proxy servers for access to Internet

Please read it https://bugzilla.mozilla.org/show_bug.cgi?id=747113
(Reporter)

Comment 1

5 years ago
When I change network.auth.force-generic-ntlm to true, the problem is partial solved.
Component: Untriaged → Build Config
OS: Windows XP → All
Hardware: x86 → All
(Reporter)

Updated

5 years ago
Flags: needinfo?(mcmanus)
I see a needinfo flag but I don't see a question.
Flags: needinfo?(mcmanus)
(Reporter)

Comment 3

5 years ago
I need know if the proposal to set network.auth.force-generic-ntlm to true by default because nobody answer to me.
This is definitely a WONTFIX.  The preference here is just a fallback in case of problems.  We prefer use of the system APIs when possible to do the proper NTLM authentication.  Currently the "generic module" (I rather call it internal implementation) is completely disabled by default and will remain so until we have a good NTLMv2 capable alternative.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.