underscore in username causes publishing to fail

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jon, Assigned: mjschranz)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
A user created a username with a underscore in front, which caused popcorn maker to not save the project. Removing the _ allowed the project to save properly again.
(Assignee)

Updated

5 years ago
Assignee: nobody → schranz.m
(Assignee)

Comment 1

5 years ago
As diagnosed, the problem is actually in the MakeAPI. Right now the validator we use on URLs is actually incorrectly not allowing URLs that have that underscore in them.
Status: NEW → ASSIGNED
Component: Popcorn Maker → MakeAPI
Comment on attachment 773266 [details] [review]
https://github.com/mozilla/MakeAPI/pull/108

R+ With a comment change.
Attachment #773266 - Flags: review?(chris) → review+

Comment 4

5 years ago
Commit pushed to master at https://github.com/mozilla/MakeAPI

https://github.com/mozilla/MakeAPI/commit/dc92315ebf19e3e097b3ed3d05b2bb0b9d0b330b
Fix Bug 890655 - URL validator needs to accept underscores in hostname

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Attachment mime type: text/plain → text/x-github-pull-request
You need to log in before you can comment on or make changes to this bug.