[AccessFu] Web app support broken in current nightlies for Android

RESOLVED DUPLICATE of bug 890976

Status

()

Core
Disability Access APIs
--
major
RESOLVED DUPLICATE of bug 890976
5 years ago
5 years ago

People

(Reporter: MarcoZ, Assigned: yzen)

Tracking

({regression})

Trunk
All
Android
regression
Points:
---

Firefox Tracking Flags

(firefox23 unaffected, firefox24 unaffected, firefox25 affected)

Details

(Reporter)

Description

5 years ago
STR:
1. Start Nightly.
2. Go to Menu -> Tools -> Apps.
3. Select the Market Place link.
4. Download any of the free apps like Twitter or Wikipedia.
5. Close the tab.
6. Close Nightly.
7. Execute one of the shortcuts created on your home screen for the web app just installed.

Expected: It should be accessible like any web content in Firefox.
Actual: TalkBack says "Web app", but nothing is accessible.

Tis is a regression, it used to work just fine. No regression range known yet, but I suspect it may have something to do with the way we load tabs or content scripts or the like.
(Reporter)

Comment 1

5 years ago
The same happens if you bring up Menu -> Tools -> Apps after you installed an app, and then double-tap one of the installed apps. It also launches the external shortcut as the home screen does, and even when launched from Nightly, the app itself is not accessible.
(Reporter)

Comment 2

5 years ago
It turns out that each instance of Firefox does manage its own set of web apps. I was able to determine that Firefox 23 Beta and Firefox 24 Aurora are not affected by this bug, but this is a recent regression introduced after the merger on June 24 where Nightly became Firefox 25.
status-firefox23: --- → unaffected
status-firefox24: --- → unaffected
status-firefox25: --- → affected
(Assignee)

Updated

5 years ago
Assignee: nobody → yura.zenevich
(Assignee)

Comment 3

5 years ago
It seems like there's a syntax error:
[JavaScript Error: "SyntaxError: missing ] after element list" {file: "chrome://browser/content/WebAppRT.js" line: 33 column: 46 source: "    pref("media.useAudioChannelService", true);

Removing the semicolon and rebuilding fixes the issue with starting the apps. Once loaded, the app is accessible similarly to any web content in Firefox.
(Assignee)

Updated

5 years ago
Depends on: 890976
This is being solved in bug 890976, no need to have two bugs open for the same issue.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
No longer depends on: 890976
Resolution: --- → DUPLICATE
Duplicate of bug: 890976
You need to log in before you can comment on or make changes to this bug.