Closed Bug 890745 Opened 9 years ago Closed 9 years ago

Unable to enter URL into location bar

Categories

(Firefox :: Untriaged, defect)

22 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: iain, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

This issue is sporadic on starting Firefox and I cannot determine any pattern to reproduce the problem...sometimes it persists, other times there is no issue


Actual results:

On starting Firefox the entire location bar is greyed-out. All windows work but it is impossible to enter a URL, only follow links.

It is possible to Ctrl+A the URL and paste into, say, Notepad, but you cannot paste into the location bar, delete or alter it. This applies to all tabs including new (Ctrl+T) tabs. However, a new window (Ctrl+N) opens and the location bar then works properly. On-page fields work as well, so you can navigate say by going to Google and entering the URL into the on-page input field and following the link provided and I can get to Google via the bookmarkes toolbar which leads to the next issue...

The bookmarks and navigation bar can simply not appear; you open Fx and it's in something like a locked-down popped window format with no nav or bookmark toolbars. They are enabled in the View menu, but are not visible, and switching them off and on again does not help things.

Often closing down FF/Fx and restarting the machine cures the issue(s), but sometimes it's necessary to Ctrl+N and drag your remembered tabs to the new window to get back to a workable browser.

This has happened through numerous FF/Fx versions and is on Win 7 fully patched. It is NOT related to the specific version of Firefox.


Expected results:

It would be nice just to have a consistent working browser. There seems no rhyme nor reason to this. One time everything is fine. Close down the machine, restart, opend Fx and look an unusable location bar. Restart and it may go...or it may not in which case Ctrl+N, drag yours tabs over to the new working window and ditech the non-working window. Very frustrating....
Reset Firefox 

Firefox > Help > Troubleshooting > reset firefox

will delete all addons and prefs

will not delete bookmarks and history
@kdurant35rules:

If this ocuured after adding an add-on it would make more sense to do this, but it comes and it goes on a sporadic basis with the same add-ons in use and unchanged, and so zapping all my code dev add-ons to correct a problem that often doesn't exist with the add-ons in place doesn't seem a practical solution. So to be clear:

 - This has been occursing for months across numerous different Fx versions
 - This can happen after a machine restart or may go away after a restart
 - The add-ons in use do not alter while this coming and going behaviour happens

I don't see therefore that a config that was working perfectly yesterday but then doesn't today will be ficex by removing all add-ons that were in use yesterday when everything was well...
have you just tried to reset.

it would be better (and faster) to ask an question here
https://support.mozilla.org/en-US/questions/new
Can try a reset and I presume re-install of all add-ons, but note that while the initially opened window and all tabs within it are in this greyed-out location bar state, a Ctrl+N window works just fine with no location bar problems. Hence it's not too promising that a reset will work as a new window running the same add-ons works fine which suggests an add-on is not the cause of the problem as otherwise the new window would be similarly affacted.

Also, restarts of the machine can also result in the same browser with the same add-ons working fine...odd behaviour and hard to identify what triggers the behaviour.
Okay, some more feedback and it's interesting...

I have not yet altered anything wanting to get other stuff completed before 'playing' with Fx, however, I had opened a new window (Ctrl+N) which gave me a single tab which would permit input to the location bar. I was using this as I got through work and Fx then crashed and auto-restarted. Now the interesting bit...

Prior to the crash I had the original Fx window with multiple tabs all of which had input to the location bar disabled + the new Fx single (no) tab window where the location bar worked normally (inut permitted as usual). After the restart both windows reopened, but now the 'main' window with many tabs is working correctly and the 'new' single/no tab window has instead got a disabled location bar - so the behaviour of the two windows has swapped.

So before:
Original window, several tabs (~12) all with location input disabled/greyed-out location bar
New window, one/no tabs, location input working as usual, e.g. manual input of a URL permitted

Fx crash and auto-restart

Original window, several tabs, location input now working normally
New window (one/no tabs), location input now disabled/greyed-out

Now for Fx to restart with the same Add-Ons and the window behaviour to swap seems more than odd, and I don't see how a 'bad' add-on is likely to disable URL input in one window while permitting it in another, and then swap the behaviour. It's almost like race behaviour between the two windows and this time the main window got the 'good' profile data???
Oh and I should add:

In the new 'crippled' window, the window that was working correctly prior to the crash, not only has input to the location bar been disabled but the bookmark toolbar has gone *plus the back and forward nav buttons*.

The window also now shows the 'Add new tab' + tab at the top, although this is also inoperative
Hello,

Your issue is a support request and so Bugzilla is not equipped to handle these kinds of requests. We took the liberty to copy your issue over to our support platform, where your issue can be taken care of. In the next few minutes you'll receive an email that an account on support.mozilla.org was created. You just need to click the confirmation link, and your support request will be made live.

If you wish to log-in to respond and leave additional information to your support request, please use this link to request a new password: https://support.mozilla.org/users/pwreset to get you all up and running.

We'll close this bug at this point, please continue on the support request on the support platform located at https://support.mozilla.org so the specialists there are able to assist you further.

Thank you.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
Can I ask why this has been closed, marked as invaluid and moved to support? THIS IS NOT A SUPPORT ISSUE...this is reporting incorrect behaviour of Fx and I would have expected someone to be interested in diagnosing why the product periodically locks out the location bar, particularly when it is so inconsistent in its behaviour
You need to log in before you can comment on or make changes to this bug.