Last Comment Bug 890763 - localeCompare support for options
: localeCompare support for options
Status: RESOLVED DUPLICATE of bug 853301
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: 23 Branch
: All All
-- normal (vote)
: ---
Assigned To: Norbert Lindenberg
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks: es-intl
  Show dependency treegraph
 
Reported: 2013-07-07 20:31 PDT by Rob Hudson [:robhudson]
Modified: 2013-07-15 22:16 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image Rob Hudson [:robhudson] 2013-07-07 20:31:11 PDT
According to MDN, localeCompare could accept options to adjust, e.g., sensitivity, ignore punctuation, etc. Chrome supports this since version 24. It'd be nice if Firefox could add support also.

See: https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/String/localeCompare#Parameters
Comment 1 User image Norbert Lindenberg 2013-07-15 22:16:27 PDT
That's been implemented under bug 769871; it just needs to be turned on through bug 853301.

*** This bug has been marked as a duplicate of bug 853301 ***

Note You need to log in before you can comment on or make changes to this bug.