Assertion failure: "expected mAllowZoom to be the same on both nsStyleFonts"

RESOLVED FIXED in mozilla25

Status

()

Core
SVG
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Jesse Ruderman, Assigned: heycam)

Tracking

(Blocks: 2 bugs, {assertion, regression, testcase})

Trunk
mozilla25
x86_64
Mac OS X
assertion, regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 771919 [details]
testcase

Assertion failure: mAllowZoom == aOther.mAllowZoom (expected mAllowZoom to be the same on both nsStyleFonts), at layout/style/nsStyleStruct.cpp:189

This assertion was added in bug 842181.

Does not crash in a non-debug build.
(Reporter)

Comment 1

5 years ago
Created attachment 771920 [details]
stack
(Assignee)

Comment 2

5 years ago
Created attachment 778938 [details] [diff] [review]
patch

When computing -x-text-zoom, I shouldn't be re-setting mAllowZoom when the rule data is null for that property, right?  I should just leave it at whatever the start struct has.
Assignee: nobody → cam
Status: NEW → ASSIGNED
Attachment #778938 - Flags: review?(dbaron)
Comment on attachment 778938 [details] [diff] [review]
patch

Yes.  You should *never* touch the style data when the value is eCSSUnit_Null.  It means the property wasn't specified in the rules you've looked at -- which might be because it's not specified or might be because you copy-constructed the style struct off of a partially computed aStartStruct that did have it specified.
Attachment #778938 - Flags: review?(dbaron) → review+

Comment 6

5 years ago
https://hg.mozilla.org/mozilla-central/rev/a06720bea809
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
You need to log in before you can comment on or make changes to this bug.