Last Comment Bug 891161 - about:apps page on FxAndroid has a marketplace link pointing to https://marketplace.mozilla.org, not https://marketplace.firefox.com
: about:apps page on FxAndroid has a marketplace link pointing to https://marke...
Status: RESOLVED FIXED
[good first bug][mentor=mfinkle@mozil...
:
Product: Firefox for Android
Classification: Client Software
Component: Web Apps (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: Firefox 25
Assigned To: Saurabh Nair [:jsx] (not reading all bugmail. ni? if you need me)
: Aaron Train [:aaronmt]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-08 16:53 PDT by Jason Smith [:jsmith]
Modified: 2013-07-12 10:58 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Marketplace Link (51.40 KB, image/png)
2013-07-08 16:53 PDT, Jason Smith [:jsmith]
no flags Details
Attaching patch (844 bytes, patch)
2013-07-11 06:36 PDT, Saurabh Nair [:jsx] (not reading all bugmail. ni? if you need me)
mark.finkle: review+
Details | Diff | Splinter Review

Description Jason Smith [:jsmith] 2013-07-08 16:53:54 PDT
Created attachment 772390 [details]
Marketplace Link

Build: Firefox 25 Nightly
Device: Galaxy Nexus
OS: Android 4.2

STR

1. Go to about:apps
2. Long press the marketplace link

Expected

The link should point to https://marketplace.firefox.com.

Actual

The link points to https://marketplace.mozilla.org.
Comment 2 Saurabh Nair [:jsx] (not reading all bugmail. ni? if you need me) 2013-07-09 12:51:51 PDT
I would like to get started with contributing code. I've no previous experience contributing code to Mozilla. Can I take this and work on this?
Comment 3 Aaron Train [:aaronmt] 2013-07-09 12:57:05 PDT
Sure thing.
Comment 4 Saurabh Nair [:jsx] (not reading all bugmail. ni? if you need me) 2013-07-09 13:02:15 PDT
Thanks. As I said, this is my first time. So this might be a stupid question. Is there a git repo that I can clone and make the modification and send in a patch?
Comment 5 Aaron Train [:aaronmt] 2013-07-09 13:06:44 PDT
I suggest reading through https://wiki.mozilla.org/Mobile/Fennec/Android and first getting a build up and running that you can install to your device or emulator. Feel free to hop on to #mobile on irc.mozilla.org to chat with us and if you need assistance.

https://developer.mozilla.org/en-US/docs/Developer_Guide

Building Fennec: https://wiki.mozilla.org/Mobile/Fennec/Android#Building_Fennec
Getting the source: https://wiki.mozilla.org/Mobile/Fennec/Android#Getting_the_source
Comment 6 Saurabh Nair [:jsx] (not reading all bugmail. ni? if you need me) 2013-07-09 13:12:52 PDT
Thanks for the detailed info Aaron. I'll do that.
Comment 7 Saurabh Nair [:jsx] (not reading all bugmail. ni? if you need me) 2013-07-11 02:08:43 PDT
I've made the change and created a pull request in Github.

https://github.com/mozilla/mozilla-central/pull/15

Will this be ok? Or do I need to upload a patch?
Comment 8 Saurabh Nair [:jsx] (not reading all bugmail. ni? if you need me) 2013-07-11 06:36:44 PDT
Created attachment 773941 [details] [diff] [review]
Attaching patch
Comment 9 Aaron Train [:aaronmt] 2013-07-11 06:46:28 PDT
We use Mercurial not the Github mirror, so the patch will need to be Mercurial based https://developer.mozilla.org/en-US/docs/Mercurial_FAQ
Comment 10 Saurabh Nair [:jsx] (not reading all bugmail. ni? if you need me) 2013-07-11 07:10:14 PDT
Is there anyway I can clone the just the 'mobile' directory from the repo rather than the entire mozilla-central repo?
Comment 11 Ryan VanderMeulen [:RyanVM] 2013-07-11 13:47:02 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/9f3556f19859
Comment 12 Saurabh Nair [:jsx] (not reading all bugmail. ni? if you need me) 2013-07-11 21:34:26 PDT
Is there any further action required from me? Because I got an email saying patch approved.
Comment 13 Mark Finkle (:mfinkle) (use needinfo?) 2013-07-11 21:40:36 PDT
(In reply to Saurabh Nair [:jsx] from comment #12)
> Is there any further action required from me? Because I got an email saying
> patch approved.

Nope. The patch was landed on mozilla-inbound and will make it's way to mozilla-central (and Nightly) soon.

Thanks for the patch Saurabh. We hope you find another bug to work on next. Drop by #mobile on IRC if you want to talk about next bug opportunities.
Comment 14 Saurabh Nair [:jsx] (not reading all bugmail. ni? if you need me) 2013-07-11 22:48:28 PDT
(In reply to Mark Finkle (:mfinkle) from comment #13)
> Drop by #mobile on IRC if you want to talk about next bug opportunities.

Sure, I'll Mark. Thanks for all the help, Mark and Aaron.
Comment 15 Ryan VanderMeulen [:RyanVM] 2013-07-12 10:58:56 PDT
https://hg.mozilla.org/mozilla-central/rev/9f3556f19859

Note You need to log in before you can comment on or make changes to this bug.