startup crash in mozilla::gl::GLContextEGL::MakeCurrentImpl @ eglMakeCurrent on LG Optimus Black (LG P970) running GB

RESOLVED WONTFIX

Status

()

Core
Graphics
--
critical
RESOLVED WONTFIX
4 years ago
11 months ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, qawanted})

23 Branch
ARM
Android
crash, qawanted
Points:
---

Firefox Tracking Flags

(firefox22 affected, firefox23- affected, firefox24 affected, firefox25 affected, relnote-firefox 23+)

Details

(Whiteboard: [native-crash][startupcrash], crash signature)

(Reporter)

Description

4 years ago
It replaces bug 856445.

Here is the breakdown per device over the last day:
* 22.0:
LGE LG-P970 	7
LGE LG-P970h 	2
* 23.0 Beta:
LGE LG-P970h 	9
LGE LG-P970 	9

Signature 	eglMakeCurrent More Reports Search
UUID 	f1d19e17-0c28-4fa4-b3ab-5becb2130709
Date Processed	2013-07-09 01:50:42.840794
Uptime	7
Last Crash	26 seconds before submission
Install Age 	337991 since version was first installed.
Install Time 	2013-07-05 03:57:19
Product 	FennecAndroid
Version 	23.0
Build ID 	20130701142603
Release Channel 	beta
OS 	Android
OS Version 	0.0.0 Linux 2.6.35.7+ #1 PREEMPT Mon Jan 2 14:42:50 IST 2012 armv7l lge/lge_bproj/bproj_sea-xxx:2.3.
Build Architecture 	arm
Build Architecture Info 	ARMv0 | None
Crash Reason 	SIGSEGV
Crash Address 	0x17
App Notes 	
AdapterDescription: 'Imagination Technologies -- PowerVR SGX 530 -- OpenGL ES 2.0 -- Model: LG-P970, Product: lge_bproj, Manufacturer: LGE, Hardware: lge'
LGE LG-P970
lge/lge_bproj/bproj_sea-xxx:2.3.4/GRJ22/LG-P970-V20b.479621F1:user/release-keys
Adapter Vendor ID 	Imagination Technologies
Adapter Device ID 	PowerVR SGX 530
Android CPU ABI 	armeabi-v7a
Android Manufacturer 	LGE
Android Model 	LG-P970
Android Version 	10 (REL)

Frame 	Module 	Signature 	Source
0 	libEGL.so 	eglMakeCurrent 	
1 	libEGL.so 	eglReleaseThread 	
2 	libxul.so 	mozilla::gl::GLContextEGL::MakeCurrentImpl(bool) 	gfx/gl/GLLibraryEGL.h
3 	libxul.so 	mozilla::gl::GLContextEGL::Init() 	gfx/gl/GLContext.h
4 	libxul.so 	mozilla::gl::GLContextEGL::CreateGLContext(mozilla::gfx::SurfaceCaps const&, mozilla::gl::GLContextEGL*, bool, void*, void*) 	gfx/gl/GLContextProviderEGL.cpp
5 	libxul.so 	mozilla::gl::GLContextProviderEGL::CreateForWindow(nsIWidget*) 	gfx/gl/GLContextProviderEGL.cpp
6 	libxul.so 	mozilla::layers::CompositorOGL::CreateContext() 	gfx/layers/opengl/CompositorOGL.cpp
7 	libxul.so 	mozilla::layers::CompositorOGL::Initialize() 	gfx/layers/opengl/CompositorOGL.cpp
8 	libxul.so 	mozilla::layers::LayerManagerComposite::Initialize() 	gfx/layers/composite/LayerManagerComposite.cpp
9 	libxul.so 	mozilla::layers::CompositorParent::AllocPLayerTransaction(mozilla::layers::LayersBackend const&, unsigned long long const&, mozilla::layers::TextureFactoryIdentifier*) 	gfx/layers/ipc/CompositorParent.cpp
10 	libxul.so 	mozilla::layers::PCompositorParent::OnMessageReceived(IPC::Message const&, IPC::Message*&) 	obj-firefox/ipc/ipdl/PCompositorParent.cpp
11 	libxul.so 	mozilla::ipc::SyncChannel::OnDispatchMessage(IPC::Message const&) 	ipc/glue/SyncChannel.cpp
12 	libxul.so 	mozilla::ipc::RPCChannel::OnMaybeDequeueOne() 	ipc/glue/RPCChannel.cpp
13 	libxul.so 	RunnableMethod<IPC::ChannelProxy::Context, void (IPC::ChannelProxy::Context::*)(), Tuple0>::Run() 	ipc/chromium/src/base/tuple.h
14 	libxul.so 	mozilla::ipc::RPCChannel::DequeueTask::Run() 	obj-firefox/dist/include/mozilla/ipc/RPCChannel.h
15 	libxul.so 	MessageLoop::RunTask(Task*) 	ipc/chromium/src/base/message_loop.cc
16 	libxul.so 	MessageLoop::DeferOrRunPendingTask(MessageLoop::PendingTask const&) 	ipc/chromium/src/base/message_loop.cc
17 	libxul.so 	MessageLoop::DoWork() 	ipc/chromium/src/base/message_loop.cc
18 	libxul.so 	base::MessagePumpDefault::Run(base::MessagePump::Delegate*) 	ipc/chromium/src/base/message_pump_default.cc
19 	libxul.so 	MessageLoop::RunInternal() 	ipc/chromium/src/base/message_loop.cc
20 	libxul.so 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
21 	libxul.so 	base::Thread::ThreadMain() 	ipc/chromium/src/base/thread.cc
22 	libxul.so 	ThreadFunc 	ipc/chromium/src/base/platform_thread_posix.cc
23 	libc.so 	__thread_entry 	
24 	libc.so 	pthread_create

More reports at:
https://crash-stats.mozilla.com/report/list?product=FennecAndroid&signature=eglMakeCurrent
(Reporter)

Comment 1

4 years ago
It's currently #2 top crasher in the first hours of 23.0.
Brad, do you or somebody on your team have one of these phones?
Flags: needinfo?(blassey.bugs)
QA has one in Mountain View
Flags: needinfo?(blassey.bugs)

Comment 4

4 years ago
I got a LG Optimus Black here, but it's running Android 4.0.4.   It isnt crashing on startup, as the bug title says, so i'll try poking at the set of reported URLs that it's crashing on.
(Reporter)

Comment 5

4 years ago
(In reply to Tony Chung [:tchung] from comment #4)
> I got a LG Optimus Black here, but it's running Android 4.0.4.   It isnt
> crashing on startup, as the bug title says, so i'll try poking at the set of
> reported URLs that it's crashing on.
You need to install Gingerbread to make it crash on startup.
tracking-firefox23: --- → ?
Keywords: topcrash

Comment 6

4 years ago
Waiting for more time to pass and stabilize the top crash list, qa testing on this phone, and whether there's been user outreach about this (needinfo on Tyler for that).
Flags: needinfo?(tdowner)
Keywords: qawanted
We have not had any user outreach on this, and honestly aren't 100% sure on how to do so (We don't collection crash emails on android ATM AFAIK and have no other way of discerning users reliably). What are we looking for here?
Flags: needinfo?(tdowner)
(In reply to Tyler Downer [:Tyler] from comment #7)
> We have not had any user outreach on this, and honestly aren't 100% sure on
> how to do so (We don't collection crash emails on android ATM AFAIK and have
> no other way of discerning users reliably). What are we looking for here?

Any comments in the Play Store as well as if we get traffic on sumo from Android users to the point where it might be worth it to put up a 'hot topic' article asking them if they're seeing this issue?  Also perhaps we could alter the "What's New?" section in the Google Play store to say this is a known issue and provide a bug template short url or something where affected users could get in touch?
Flags: needinfo?(tdowner)
(Reporter)

Comment 9

4 years ago
(In reply to Alex Keybl [:akeybl] from comment #6)
> Waiting for more time to pass and stabilize the top crash list
It's #6 top crasher three days after the release with many duplicates though (not surprising for a startup crash).
There are currently no ratings on the google play store for any of the 4 variants of the Black and Firefox 23. I don't see any feedback on input either, which isn't surprising seeing as users experiencing a startup crash would never even know about input. We will keep our eyes open but so far, there hasn't been any data.
Flags: needinfo?(tdowner)
Tony can you report back on your investigation with the reported URLs?
Flags: needinfo?(tchung)
QA Contact: tchung
(Reporter)

Updated

4 years ago
status-firefox24: --- → affected
status-firefox25: --- → affected
(In reply to lsblakk@mozilla.com [:lsblakk] from comment #11)
> Tony can you report back on your investigation with the reported URLs?

we've tried testing this, but unfortunately our device is android 4.0.4 so these crashes dont happen. (i've tried testing the urls that kevin sent me).   I am told these crashes on Android 2.3 (gingerbread), which we dont have.   

We've asked Erin to work with serviceNow team to request one and send to toronto
Flags: needinfo?(tchung)

Comment 13

4 years ago
In bug 856445 we had crash issues with Android 4, so Kevin IIRC updated the device to that, so I guess that's why this device doesn't have GB any more. Too bad that now this problem shows up as an issue with the old system. :(
We're not doing a mobile 23.0.1 so this isn't tracking for 23 but I've added it to the known issues in the 23 notes.
tracking-firefox23: ? → -
relnote-firefox: --- → 23+
No longer a top crash in recent/upcoming releases. Triage suspects this is because Android 2.3 LG Optimus Black users are no longer using Firefox. As sad as this is, it's not a flagship phone and can be deprioritized.
Keywords: topcrash
This crash is still being reported although these seems to be isolated to Gingerbread. Since we're dropping support for Gingerbread I'm going to close this as WONTFIX. Please reopen this bug report if you can reproduce the crash on a current Fennec version.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.