CSS1 border styles on checkboxes/radio buttons are ignored

RESOLVED INVALID

Status

()

Core
Layout: Form Controls
P4
minor
RESOLVED INVALID
17 years ago
16 years ago

People

(Reporter: Skewer, Assigned: rods (gone))

Tracking

({access, css1, testcase})

Trunk
Future
access, css1, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Procedure: View checkbox CSS1 testcase.

Expected: Inner size of form controls remain same size, and borders expand outward.

Actual: Borders expand into the control, making it difficult or impossible to read.

Build: 2001070204 Win98
(Reporter)

Comment 1

17 years ago
Created attachment 41100 [details]
Checkbox CSS1 testcase
(Reporter)

Updated

17 years ago
Keywords: access, css1, nsbeta1
(Reporter)

Updated

17 years ago
Keywords: testcase

Comment 2

17 years ago
Over to HTML Form Controls.
Assignee: pierre → rods
Component: Style System → HTML Form Controls
QA Contact: ian → madhur
(Reporter)

Comment 3

17 years ago
Can anyone think of a way that this bug might cause dataloss?
(Assignee)

Comment 4

17 years ago
I am not sure if this is a bug or not, the forms.css sets the width and height, 
if the user set those to appropriately larger values it would look fine.

We could set ! important on the borders and such in forms.css and that would 
ends this behavior also.
Severity: major → minor
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: --- → Future

Updated

17 years ago
Blocks: 104166
(Reporter)

Updated

17 years ago
Keywords: nsbeta1, nsCatFood
Marking nsbeta1-
Keywords: nsbeta1 → nsbeta1-
(Assignee)

Updated

17 years ago
Priority: P2 → P4

Comment 6

16 years ago
rods@netscape.com, this is more of a question than a comment.  I am attempting
to build a stylesheet that changes the border of checkboxes to a solid (flat)
edge.  Only through researching the bug reports related to checkboxes did I
stumble upon the existence of forms.css and the ! important keyword.

I am curious why anything in forms.css is marked as ! important.  Is there an
overriding concern that authors could design a stylesheet that confused the user
too much by removing borders from key UI elements?

This seems particularly strange to me because in my attempt to build a
stylesheet for form elements, I have been successful in setting the borders for
text inputs and textareas, but not select lists or checkboxes.  Hence, it is
possible for me to build a inconsistently customized user interface but not a
fully customized consistent one.

Sure, I can go into -my- forms.css and remove the ! important from border-width:
2px and border-style: inset, and my stylesheet then works as intended.  But no
other users would see what I see.

I do not mean to be critical of the decision, I am just curious if you could
educate me on why the ! important keyword is present in forms.css at all.
(Reporter)

Comment 7

16 years ago
That was done as a workaround to this bug (In the past the items were unusable,
currently the border-width style is ignored). However, the current behavior is
still wrong, because now Mozilla is completely ignoring author border-width
styles. What we need is for the size of checkboxes/radio buttons to expand as
the size of the border expands, or vice versa if necessary.
Summary: CSS1 borders on checkboxes/radio buttons can make them unusable → CSS1 border styles on checkboxes/radio buttons are ignored

Comment 8

16 years ago
I think this is All/All.
OS: Windows 98 → All
Hardware: PC → All
CSS1 has nothing to do with form controls.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.