The default bug view has changed. See this FAQ.

RSS feed does not get latest posts

RESOLVED FIXED in Thunderbird 26.0

Status

MailNews Core
Feed Reader
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: a.vankaam, Assigned: alta88)

Tracking

Thunderbird 26.0
x86_64
Linux

Thunderbird Tracking Flags

(thunderbird24 fixed, thunderbird25 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

2.07 KB, patch
Magnus Melin
: review+
Details | Diff | Splinter Review
(Reporter)

Description

4 years ago
User Agent: Opera/9.80 (X11; Linux x86_64) Presto/2.12.388 Version/12.15

Steps to reproduce:

Edit, account settings, account actions, add other account, blogs & news feeds, next, next, finish.
Right click the created Blogs & News feeds and select subscribe
Enter URL: http://www.gamingonlinux.com/article_rss.php
Press ADD
close dialog



Actual results:

It will download the last 15 articles, at this moment when I write this the latest entry it shows is "Limit Theory Developer Update on Linux Port"  which was from 3 days ago.  


Expected results:

It should have gotten the 8 entries which has been posted since then but it does not.

Going with a web browser to http://www.gamingonlinux.com/article_rss.php shows them.
Using opera RSS feeds shows them.
Using Akregator RSS reader shows them.
Using the thunderbird add on bamboo shows them.

Get messages does not get anything new, restarting to make it check on restart does not get anything new

Feeds.logging.console set to debug shows:

2013-07-09 16:55:50	Feeds	DEBUG	downloadFeed: START x/# foldername:uri - 1/1 GamingOnLinux.com Latest articles:mailbox://nobody@Feeds-2/GamingOnLinux.com%20Latest%20articles
2013-07-09 16:55:50	Feeds	DEBUG	downloadFeed: CONTINUE foldername:urlArray - GamingOnLinux.com Latest articles:http://www.gamingonlinux.com/article_rss.php
2013-07-09 16:55:50	Feeds	DEBUG	downloadFeed: DOWNLOAD feed url - http://www.gamingonlinux.com/article_rss.php
2013-07-09 16:55:50	Feeds	DEBUG	downloadFeed: Finished with folder - GamingOnLinux.com Latest articles
2013-07-09 16:55:50	Feeds	DEBUG	Feed.onDownloaded: got a download - http://www.gamingonlinux.com/article_rss.php
2013-07-09 16:55:50	Feeds	DEBUG	FeedParser.parseFeed: type:url - RSS_2.0 : http://www.gamingonlinux.com/article_rss.php
2013-07-09 16:55:50	Feeds	DEBUG	FeedParser.parseAsRSS2: channel nsURI - 
2013-07-09 16:55:50	Feeds	DEBUG	Feed.invalidateItems: for url - http://www.gamingonlinux.com/article_rss.php
2013-07-09 16:55:50	Feeds	DEBUG	FeedParser.parseAsRSS2: items to parse - 15
2013-07-09 16:55:51	Feeds	DEBUG	Feed.removeInvalidItems: for url - http://www.gamingonlinux.com/article_rss.php
2013-07-09 16:55:51	Feeds	DEBUG	downloaded: Update errorCode:feedName:folder - 0 : GamingOnLinux.com Latest articles : /media/realcrypt1/Thunderbird/default/Mail/Feeds-2-1/GamingOnLinux.com Latest articles
(Assignee)

Comment 1

4 years ago
this works for me (linux, Tb25).  as of this moment, all 15 current articles were downloaded, starting from Project 64 to Infested Planet (newest), which is what the file contains.
(Assignee)

Comment 2

4 years ago
but, in fact, updates do not work.  the stale cached file is being used..
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

4 years ago
Created attachment 773308 [details] [diff] [review]
patch
Assignee: nobody → alta88
Attachment #773308 - Flags: review?(mbanner)
(Assignee)

Comment 4

4 years ago
Comment on attachment 773308 [details] [diff] [review]
patch

[Approval Request Comment]

this is borderline data lossy; risk is low.
Attachment #773308 - Flags: approval-comm-aurora?
(Reporter)

Comment 5

4 years ago
thank you for solving this as fast as you did.  Is there anyway to incorporate this patch in TB17 ? don't see a feed.js anything so assume its compiled in somewhere
(Assignee)

Comment 6

4 years ago
(In reply to a.vankaam from comment #5)
> thank you for solving this as fast as you did.  Is there anyway to
> incorporate this patch in TB17 ? don't see a feed.js anything so assume its
> compiled in somewhere

it's not up to me, but it could go into a .0x of 17, though there may never be one.  also, it's hard to say how widespread it is but i suspect it may have to do with how that server sets headers.  for one, they don't respond with 304 on a failed If-Modified-Since.

anyway, you could unzip omni.ja, find Feed.js, and insert the 2 lines, and rearchive (or find an in place archive editor).  it's not compiled.
Component: Untriaged → Feed Reader
Product: Thunderbird → MailNews Core
(Assignee)

Comment 7

4 years ago
ping?
(Assignee)

Comment 8

4 years ago
Created attachment 788110 [details] [diff] [review]
feedCache.patch


add check to avoid error needing restart.
Attachment #773308 - Attachment is obsolete: true
Attachment #788110 - Flags: review?(mbanner)
Attachment #788110 - Flags: approval-comm-beta?
Attachment #788110 - Flags: approval-comm-aurora?
Attachment #773308 - Flags: review?(mbanner)
Attachment #773308 - Flags: approval-comm-aurora?
Comment on attachment 788110 [details] [diff] [review]
feedCache.patch

I've just not had time to look at this, maybe Magnus can.
Attachment #788110 - Flags: review?(mbanner) → review?(mkmelin+mozilla)

Comment 10

4 years ago
Comment on attachment 788110 [details] [diff] [review]
feedCache.patch

Review of attachment 788110 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me! r=kmelin
Attachment #788110 - Flags: review?(mkmelin+mozilla) → review+
https://hg.mozilla.org/comm-central/rev/d3212436fe26
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 26.0
Comment on attachment 788110 [details] [diff] [review]
feedCache.patch

I'd certainly like to get this out for some testing. a=Standard8
Attachment #788110 - Flags: approval-comm-beta?
Attachment #788110 - Flags: approval-comm-beta+
Attachment #788110 - Flags: approval-comm-aurora?
Attachment #788110 - Flags: approval-comm-aurora+
https://hg.mozilla.org/releases/comm-aurora/rev/3749620ed694
https://hg.mozilla.org/releases/comm-beta/rev/02c97ea66fa0
status-thunderbird24: --- → fixed
status-thunderbird25: --- → fixed
You need to log in before you can comment on or make changes to this bug.