[B2G][Email] The contacts list cannot by displayed in full view after the keyboard has been invoked

RESOLVED FIXED in Firefox OS v1.1hd

Status

--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: nkot, Assigned: rexboy)

Tracking

unspecified
1.1 QE4 (15jul)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 verified, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix, b2g-v1.1hd fixed)

Details

(Whiteboard: [LeoVB+])

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 772695 [details]
screenshot

Description:
When the user is attempting to add "cc" or "bcc" contact from the contacts list after the keyboard has been invoked (typing in the subject or email body), the contacts list is displayed partially, lower half of the screen is white out

Prerequisites:
have contacts list available on the test device

Repro Steps:
1) Updated to Leo Build ID: 20130708070214
2) Open Email app
3) Select to create a new message
4) Type in the subject line 
5) Add "bcc" recipient from the contacts list ("+")
6) Scroll down the contacts list

Actual:
 Lower part of the screen is white out, contacts list displays only at the top

Expected:
 Contacts list opens up in full view

Environmental Variables
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/8c0127cc7be3
Gaia: 7c40bdaeaffae708342fc773926dcfac5389348e
Platform Version: 18.1

Notes:
Repro frequency: 100%
See attached screenshot
(Reporter)

Comment 1

5 years ago
Created attachment 772697 [details]
logcat
The contacts list is provided by the contacts app, triggered via webactivity.  This seems like a contacts regression or system regression interfering with contacts.
Component: Gaia::E-Mail → Gaia::Contacts
I just tried with a recent gaia master and gaia v1-train using a mozilla-central gecko build.  The problem did not reproduce in either case.

I'm building a b2g18 image to see if that triggers the issue.
I was able to reproduce by flashing b2g18 gecko.

It seems like there is a compositing issue or something going on.  I am also getting weird flashing in settings app, scrolling the contacts list, etc.
My apologies.  This does appear to be a v1-train gaia issue.  I had forgotten to update my local tracking branch.
Bisecting shows that this was introduced by:

  https://github.com/mozilla-b2g/gaia/commit/5d7a0da528dce626b563abafc135eb828599d3c0

Rex, any thoughts on what is happening here?
Flags: needinfo?(rexboy)
blocking-b2g: --- → leo?

Updated

5 years ago
Assignee: nobody → rexboy
blocking-b2g: leo? → leo+

Updated

5 years ago
Severity: normal → critical
Target Milestone: --- → 1.1 QE4 (15jul)
Seems the newly added |appWindow.resize()| failed on calculating window size of inline activities.. Investigating.
Flags: needinfo?(rexboy)
Created attachment 773130 [details]
v1-train patch

Seems like a regression that I didn't discover in bug 877903..

I can reproduce it only in v1-train, but seems the code in master is just kind of "lucky hit" which is not using the correct way, so I'll patch both side.

Alive, would you help reviewing this?
Thanks a lot!
Attachment #773130 - Flags: review?(alive)
Created attachment 773133 [details]
master patch
Attachment #773133 - Flags: review?(alive)
Comment on attachment 773130 [details]
v1-train patch

There'd be chances to publish an instance event from app window so please consider to create a publish function, see the url for reference. You don't need to borrow all codes from my branch.
Attachment #773130 - Flags: review?(alive) → review+
Attachment #773133 - Flags: review?(alive) → review+
master
https://github.com/mozilla-b2g/gaia/commit/b3ef9da9c967e8f33b7b750d986d395e1aa38c95

v1-train
https://github.com/mozilla-b2g/gaia/commit/b2cb483bd6f89a7bdd4c47df256bea003bebcfba
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-b2g18: --- → fixed
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: --- → wontfix
status-b2g-v1.1hd: --- → affected
Resolution: --- → FIXED

Comment 12

5 years ago
Varified fix on leo 1.1 Mozilla RIL
Environmental Variables
Build ID: 20130716070204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/629020cf576b
Gaia: fb9362d34260771d4a00b9a0e10a6bbad397bd3b
Platform Version: 18.1
RIL Version: 01.01.00.019.138 

The user is able to see  Contacts list up in full view.
status-b2g18: fixed → verified

Updated

5 years ago
Whiteboard: [LeoVB+]
v1.1.0hd: b2cb483bd6f89a7bdd4c47df256bea003bebcfba
v1.1.0hd: 5ec8152a93acdad6319fd09446c99c1324bb059f
status-b2g-v1.1hd: affected → fixed

Updated

5 years ago
Duplicate of this bug: 897324
You need to log in before you can comment on or make changes to this bug.