Closed Bug 891445 Opened 6 years ago Closed 6 years ago

[A/V] Incorrect pointer comparion at MediaResourceManagerService::cancelClientLocked()

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:leo+, firefox23 wontfix, firefox24 wontfix, firefox25 fixed, b2g18 verified, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix, b2g-v1.1hd fixed)

RESOLVED FIXED
1.1 QE4 (15jul)
blocking-b2g leo+
Tracking Status
firefox23 --- wontfix
firefox24 --- wontfix
firefox25 --- fixed
b2g18 --- verified
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- wontfix
b2g-v1.1hd --- fixed

People

(Reporter: sotaro, Assigned: sotaro)

References

Details

(Whiteboard: [LeoVB+])

Attachments

(1 file, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #889167 +++

STR is borrowed from Bug 889167 comment #4.

1. Play any direct linked video in browser.
2. while playing, push home button.
3. Restart browser.
4. After resume the play, refresh the browser and wait playback start.

Sympton

Sometimes video playback does not start and shows loading ui forever.
blocking-b2g: leo+ → ---
Blocks: 889167
Nominate to leo+ because blocks leo+ blocker.
blocking-b2g: --- → leo?
Attachment #772750 - Flags: review?(chris.double)
By debugging using GDB, I confirmed that the while loop in cancelClientLocked() continue almost forever, because of incorrect pointer comparison.
Blocking since this blocks bug 889167, not due to the STR in comment 0. If this no longer blocks bug 889167, it is no longer a blocker.
blocking-b2g: leo? → leo+
I think this report is no longer valid because bug 889167 is duplicated of bug 884440.
Flags: needinfo?(sotaro.ikeda.g)
Blocks: 884440
Flags: needinfo?(sotaro.ikeda.g)
(In reply to leo.bugzilla.gecko from comment #5)
> I think this report is no longer valid because bug 889167 is duplicated of
> bug 884440.

Pointer comparison is incorrect in normal use case. It is still a problem of Bug 884440. MediaResourceManagerService::cancelClientLocked() does not work correctly. Current code basically works in normal use case just because of luck.
Attachment #772750 - Flags: review?(chris.double) → review+
Blocks: 882993
Add a header to the patch. Carry "chris.double: review+".
Attachment #772750 - Attachment is obsolete: true
Attachment #774669 - Flags: review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/32c3ccd8946c
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Varified,fixed on Leo Mozilla RIL.
Environmental Variables
Build ID: 20130716070204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/629020cf576b
Gaia: fb9362d34260771d4a00b9a0e10a6bbad397bd3b
Platform Version: 18.1
RIL Version: 01.01.00.019.158

The issue does not reproduce,the video playsback right where it left without any delays.
Whiteboard: [LeoVB+]
You need to log in before you can comment on or make changes to this bug.