The default bug view has changed. See this FAQ.

Alt+PgUp and Alt+PgDn to change sidebar tabs

VERIFIED FIXED in mozilla0.9.8

Status

SeaMonkey
Sidebar
P2
normal
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Aaron Leventhal, Assigned: Samir Gehani)

Tracking

(Blocks: 1 bug, {access})

Trunk
mozilla0.9.8
access

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: seeking r=, sr=)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
The Alt+Pgup and Alt+pgdn key should change what sidebar panel is open, without
focusing the new tab unless the sidebar is already focused. This is according to
the spec agreed to at
http://www.mozilla.org/projects/ui/accessibility/mozkeylist.html
(Reporter)

Updated

16 years ago
Keywords: access
(Reporter)

Updated

16 years ago
Blocks: 89148

Comment 1

16 years ago
Ok, that's enough. you don't agree to items in cvs, you agree to items in bugs 
or in newsgroups or on listservs.

I'm going to generically object to this for a week until people have time to 
think about and explain why this is important in the case that the sidebar 
isn't focused.
Whiteboard: [frivilous-objection-timeless]
(Reporter)

Comment 2

16 years ago
*** Bug 78259 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
Let me guess, it switches workspaces or something in some window managers? 
Akkana?
OS: Windows 2000 → All
Hardware: PC → All
Whiteboard: [frivilous-objection-timeless] → [frivolous-objection-timeless]

Comment 4

16 years ago
switches applications.

Comment 5

16 years ago
access
Assignee: matt → sgehani

Comment 6

16 years ago
P2 for 0.9.7
Priority: -- → P2
Target Milestone: --- → mozilla0.9.7
(Assignee)

Comment 7

16 years ago
Moving to mozilla0.9.8.
Target Milestone: mozilla0.9.7 → mozilla0.9.8
(Reporter)

Comment 8

16 years ago
Created attachment 61715 [details] [diff] [review]
Thoroughly tested, even with an empty sidebar, or a hidden sidebar
(Reporter)

Updated

16 years ago
Whiteboard: [frivolous-objection-timeless] → seeking r=, sr=

Updated

16 years ago
Attachment #61715 - Flags: superreview+

Comment 9

16 years ago
Comment on attachment 61715 [details] [diff] [review]
Thoroughly tested, even with an empty sidebar, or a hidden sidebar

sr=jag, assuming Samir finds no fault with the code.
(Assignee)

Comment 10

16 years ago
Comment on attachment 61715 [details] [diff] [review]
Thoroughly tested, even with an empty sidebar, or a hidden sidebar

r=sgehani  Nice.  Thanks.
Attachment #61715 - Flags: review+
(Reporter)

Comment 11

16 years ago
-> fixed
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 12

16 years ago
verified in 12/20 build.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.