Closed Bug 891481 Opened 7 years ago Closed 7 years ago

(jb-gonk) Supporting SENSOR_ACCELERATION to calculate orientation in gecko

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 788975

People

(Reporter: tkundu, Assigned: tkundu)

References

Details

Currently Gecko uses SENSOR_ORIENTATION to calculate  orientation. 

But SENSOR_ORIENTATION has become obsolete in android (http://developer.android.com/reference/android/hardware/Sensor.html) and android is not using that anymore.

Android Jellybean has better orientation logic which is derived using SENSOR_TYPE_ACCELEROMETER HAL events. So we want to port android orientation calculation logic in gecko and we also want gecko to use SENSOR_TYPE_ACCELEROMETER for this calculation.
Assignee: nobody → tkundu
Status: NEW → ASSIGNED
Please also note that SENSOR_TYPE_ORIENTATION is known to use more power. So it is not good to use it for orientation.
Blocks: 883051
See Also: → 788975
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 788975
You need to log in before you can comment on or make changes to this bug.