Closed Bug 891600 Opened 7 years ago Closed 3 years ago

Provider: Sync usage

Categories

(Firefox Health Report Graveyard :: Client: Android, defect, P2)

All
Android
defect

Tracking

(fennec+)

RESOLVED DUPLICATE of bug 1308337
Tracking Status
fennec + ---

People

(Reporter: rnewman, Unassigned)

References

(Blocks 2 open bugs)

Details

Early days for scoping this.
See Also: → 958561
See discussion in Bug 958561 -- this needs to track both old and FxA Sync, and needs to get out ASAP.
Blocks: 799726
tracking-fennec: --- → ?
Tracking 30, but if this could make 29 it would be great.
tracking-fennec: ? → 30+
Priority: -- → P2
Assignee: nobody → nalexander
This is valuable for engineering, but FHR data is not currently being surfaced in an actionable manner to the mobile team, so tacking this on is not a priority.
What is this bug about? Comment 0 is not helping.
(In reply to Mark Finkle (:mfinkle) from comment #4)
> What is this bug about? Comment 0 is not helping.

This ticket is the Android equivalent of Bug 958561, which adds FHR data about whether Sync is configured, what versions are in use and defaulted to, and how many syncs have succeeded/failed.

We haven't moved on this because it's technically tricky and requires co-ordination with metrics to actually define a data format that's useful for Android.
This was part of the Firefox Q1 goal for desktop to measure whether sync usage is actually driving Firefox adoption and retention. I own the analysis bits of that for now. If this is not important for the mobile team, then we can postpone or drop it, but I thought it was considered a high priority.
Flags: needinfo?(deb)
If we have this data for desktop I very much think we should also have it for Mobile. We absolutely do want to measure whether sync usage is driving adoption & retention.
Flags: needinfo?(deb)
This is unlikely to happen for 30 or 31, so being realistic and bumping to 32. We can uplift if it magically gets done sooner.

Nick, please update assigned status.
tracking-fennec: 30+ → 32+
Are we getting data form other sources on Sync usage? Otherwise, we need to do something or close this bug.
Flags: needinfo?(nalexander)
(In reply to Mark Finkle (:mfinkle) from comment #9)
> Are we getting data form other sources on Sync usage? Otherwise, we need to
> do something or close this bug.

We've been getting along with FxA data from the FxA backend team and ditto with legacy Sync data.  That tells us about everything except self-hosted legacy Sync usage.

That's been enough to understand rough user counts, sync frequency for most clients, some metrics about collection sizes, number of devices per user, etc.
Flags: needinfo?(nalexander)
Absent Nick => bumping.
tracking-fennec: 32+ → 33+
tracking-fennec: 33+ → +
I've been asked to check back on whether FxA has been integrated into FHR. :rnewman and I had an email thread a few months ago about this, and at that point he mentioned that it may get into 35 or 36.

Is there any update on this?
(In reply to Hamilton from comment #12)
> I've been asked to check back on whether FxA has been integrated into FHR.
> :rnewman and I had an email thread a few months ago about this, and at that
> point he mentioned that it may get into 35 or 36.
> 
> Is there any update on this?

No, sorry.
Assignee: nalexander → nobody
Hello again - I've gotten a few more questions from mobile stakeholders whether or not this has made it into FHR for fennec. Any updates at this point?
Hamilton: this isn't assigned to an engineer, nor is it tracking a particular release. As you know, FHR is mostly on ice, replaced by unified telemetry, but Fennec isn't really an active participant in that yet.

If this really needs to happen for a particular release, this needs to be retriaged and assigned, or an alternative approach chosen.

Presumably mobile stakeholders are already at the Fennec funnel meeting and/or triage; could you ask them to bring this up for prioritization, or ask them to contact me?
Flags: needinfo?(hulmer)
Totally understood - due diligence and all that. I'll have them contact you if it is absolutely important. This is an ask from the growth team, so I'm not sure which meetings they're at.
Flags: needinfo?(hulmer)
Superseded by Bug 1308337 and friends.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1308337
Product: Firefox Health Report → Firefox Health Report Graveyard
You need to log in before you can comment on or make changes to this bug.