Closed Bug 891930 Opened 8 years ago Closed 6 years ago

FF22 won't replicate vertical window position across sessions

Categories

(Firefox :: Session Restore, defect)

22 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: coyote2, Unassigned)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

I position the Firefox window's top left corner slightly off the screen (greater than the width of the grey line all the way around the window).

Close Firefox.


Actual results:

Next session, Firefox starts with the edges of the window well (several mm) away from the edges of the screen.


Expected results:

Exact window position should be preserved across sessions, as happened 
through FF20 (and maybe FF21).  And as many other applications do.  And as FF22 does if I close it with a window position entirely onscreen.

I treasure my monitor's vertical real estate, so I like to slightly overlap the top of the Firefox window past the top of the screen.  This is very frustrating; I tried http://www.brianapps.net/sizer/faq.html but "Sizer doesn’t work with..applications [which] don’t follow the standard way of doing things...[which don't] let the operating system handle sizing and placement of the their windows...[such as] Firefox".
p.s.  when I say that "Next session, Firefox starts with the edges of the window well (several mm) away from the edges of the screen", I several mm BELOW the top and to the right of the left edge (instead of above the top and off to the left of the edge).
I'm not sure if it's reproducible on Win 7 due to Aero Snap.
I don't see any differences between FF 20 and FF 22, Win XP.
Both versions re-position the browser window inside the desktop screen, which is expected.
Component: Untriaged → Widget
Product: Firefox → Core
Attached image FF20 screenshot
In FF20 if I closed the window like this, it looked like this on FF20 restart; whereas in FF22 if I close the window like the FF20 screenshot it looks like the next (FF22) screenshot.
Attached image FF22 screenshot
FF22 won't restart looking like the FF20 screenshot even if closed looking like it.
I added a pair of screenshots to demonstrate the change from 20 to 22.  

@Paul:  Do you think that the behavior through FF20 which I liked (and which most good programs will provide) is not desirable?  

I swear it is a change; however I'll note that the FF20 screenshot I posted just now was not created when I reverted to FF20 for testing.
1) Does it work normally with a clean profile?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

2) Are you using a special theme with Win XP?
Flags: needinfo?(coyote2)
(In reply to coyote from comment #5)
> FF22 won't restart looking like the FF20 screenshot even if closed looking
> like it.
I still cannot reproduce.
Please try the suggestions in comment 7 and also in safe mode:
http://support.mozilla.com/kb/Safe+Mode
First, I apologize for not knowing to try those things before I posted here.  However, now I have, and

The issue remain in Safe Mode.  And with a brand new Clean Profile.  And when restarting into Safe Mode with the Clean Profile.

As for XP themes, years ago I disabled XP's Themes service (so the answer is No, I am using no special WinXP theme).  

But just in case, I turned on XP's Themes service and discovered that didn't help, even in Safe Mode or with a Clean Profile or both.

In XP's Display Properties I've chosen:
Appearance Tab:  Windows and buttons:  "Windows Classic Style"
Screen Saver: None
Desktop Tab: Background = Black
Because (and only because) I did these choices, on the XP Display Properties Themes tab it says Theme = "Modified Theme".  (But I figure that no screensaver, "Windows Classic Style" windows/buttons, and black desktop background aren't a particularly special theme.)

I very much appreciate your attention!  Note that this issue presents on both of my identically-configured systems.
You can try to reproduce this with other apps (Chrome etc) to see if this is really Firefox related. But I suggest for now not to exceed the screen edges.
Thank you very much for your reply, Paul.

I already use other aps (on both computers) which do not have this bug.  (Not browsers, I don't want to use other browsers but I will if you want.)  For example, "Vuze" and "Newsbin Pro" do not have this issue; in other words, instead of insisting upon starting offset from the edges of the screen, if I close them overlapping the screen edges that's exactly how they start next time I open them.
p.s. to clear needinfo flag, pleasse see above post
You need to check the box below the comment area to clear that flag.
Flags: needinfo?(coyote2)
This issue had gone away for a few versions, but is back with FF40.
Reg range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a6104e0e5a2c&tochange=0e45f1b9521f

Jonathan Kew — bug 864107 - constrain restored window dimensions to available screen area. r=ttaubert

So it's by design.
Blocks: 864107
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Component: Widget → Session Restore
Product: Core → Firefox
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.