Closed Bug 892246 Opened 7 years ago Closed 7 years ago

Urlbar doesn't auto-show on google.com, about:healthreport on tablet

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 25
Tracking Status
firefox23 --- verified
firefox24 --- verified
firefox25 --- verified
fennec 23+ ---

People

(Reporter: liuche, Assigned: cwiiis)

References

Details

(Keywords: reproducible)

Attachments

(2 files)

Caveat: this may only be on the Asus Transformer 1, but I don't have any other tablets to test on.

The new mobile about:healthreport seems to have the default right size to make urlbar auto-show break. 

STR:
1. Go to about:healthreport (must be new mobile site - see screenshot)
2. Scroll down
3. Scroll up

Expected:
urlbar auto-shows

Actual:
Can't get urlbar to autoshow. Need to actually resize so scrolling is enabled again and urlbar shows.

This is probably something of an edge case, and probably also happens for certain webpages. (I actually just realized this happens for the "tablet" version of google.com as well.)
OS: Mac OS X → Android
Hardware: x86 → ARM
Which versions are affected here? I bet you tested on Nightly, how is Beta/Aurora?
tracking-fennec: --- → ?
To provide technical context on about:healthreport: the xhtml has the viewport set and the content inside is in an iframe.  It's possible the scrolling is never "seen" by the actual page.
Flags: needinfo?(chrislord.net)
Assignee: nobody → wjohnston
tracking-fennec: ? → 23+
I can also repro this on a 10.1" Galaxy Tab in landscape.
Also, this /might/ be fixed by my patches for bug 877602.
Chenxia, can you reproduce on today's Nightly now given bug 877602 is fixed?
Flags: needinfo?(liuche)
This is still reproducible for me (google.com), with the 7/12 nightly build, and the aurora build I just downloaded. I also did a partial mobile/android build of m-i (which includes kats's patch) and was able to repro.
Flags: needinfo?(liuche)
Keywords: reproducible
So after the patch in bug 886576, I can't reproduce this, but I have another patch that will mitigate similar problems incoming.
Flags: needinfo?(chrislord.net)
Does what it says on the tin.
Assignee: wjohnston → chrislord.net
Status: NEW → ASSIGNED
Attachment #775680 - Flags: review?(bugmail.mozilla)
Attachment #775680 - Flags: review?(bugmail.mozilla) → review+
Comment on attachment 775680 [details] [diff] [review]
Allow subdocument scrolling to reveal margins

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Scrolling in certain areas doesn't reveal/hide the toolbar
User impact if declined: The toolbar can end up hidden with few obvious ways of getting it back
Testing completed (on m-c, etc.): Tested locally
Risk to taking this patch (and alternatives if risky): Low risk, perhaps there could be situations where the dynamic toolbar is unexpectedly hidden or shown in response to user input (but I'd have thought it was always expected)
String or IDL/UUID changes made by this patch: None
Attachment #775680 - Flags: approval-mozilla-beta?
Attachment #775680 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/e7743ae9df87
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
Attachment #775680 - Flags: approval-mozilla-beta?
Attachment #775680 - Flags: approval-mozilla-beta+
Attachment #775680 - Flags: approval-mozilla-aurora?
Attachment #775680 - Flags: approval-mozilla-aurora+
Verified fixed on:
Build: Firefox for Android 24.0a2(2013-07-24)
Device: Asus Transformer TF
OS: Android 4.0.3
Status: RESOLVED → VERIFIED
Verified fixed on:
Build: Firefox for Android 23.0b10(2013-07-29)
Device: Asus Transformer TF
OS: Android 4.0.3
You need to log in before you can comment on or make changes to this bug.