prefs: colors: deselected "allow pages to choose their own colors" makes backgrounds vanish!

RESOLVED DUPLICATE of bug 306625

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 306625
4 years ago
4 years ago

People

(Reporter: dentaku, Unassigned)

Tracking

22 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130627185035

Steps to reproduce:

1. set a dark desktop themes having dark colors (e.g. DarkMint, delorean-dark-theme, gnomishdark, etc.)
=> Firefox changes colors as expected except the web page content.

2. deselected "allow pages to choose their own colors" in the content/colors preferences.
=> Firefox now also uses dark colors on webpages ... but this also makes vanish icons/images on many webpages!!! Examples:

* http://www.linux.com/
* http://www.eizo.de/microsite/flexscan.html
* http://www.ubuntuusers.de
* ...



Actual results:

When deselecting "allow pages to choose their own colors", not only the colors change in the webpage, but also misc images/icons just vanish - making the websites unusable. Not all images/icons and not on every website. 


Expected results:

Only the colors should change - the images/icons still should be displayed as before.
(Reporter)

Updated

4 years ago
Summary: prefs: colors: deselected "allow pages to choose their own colors" makes icons/images vanish with a dark theme! → prefs: colors: deselected "allow pages to choose their own colors" makes icons/images vanish!
(Reporter)

Comment 1

4 years ago
... just noticed that this occurs with bright themes, too! So it seems to be a basic problem with "allow pages to choose their own colors" (independent from theme).
Reproducible with the latest Nightly, build ID: 20130714030202, using Ubuntu 13.04 64bit

Reproducible with the latest Beta: - build ID: 	20130711122148
Reproducible with the latest Aurora: - build ID: 20130715004002

Note:
This issue also reproduces with Firefox 4.0, so it's not a regression.
Status: UNCONFIRMED → NEW
Component: Untriaged → Preferences
Ever confirmed: true

Updated

4 years ago
Summary: prefs: colors: deselected "allow pages to choose their own colors" makes icons/images vanish! → prefs: colors: deselected "allow pages to choose their own colors" makes backgrounds vanish!
(Reporter)

Comment 3

4 years ago
By the way: it's also reproducable without visiting any URL: just set the Firefox search page as default (with the firefox Logo) - after setting the above described color prefs, the firefox logo is not visible anymore!

Comment 4

4 years ago
This is a duplicate of bug 418913, which was unfortunately resolved INCOMPLETE.  It contains some comments concerning a different bug, so I am not sure this one should be marked duplicate of that one.

The problem is that the site's background coloring must be restricted, so that you don't get white text on a white image if you choose to have white text on black background; but many pages use background CSS for (hopefully) inessential images not covered by text.

A bug to make a separate pref: bug 306625 (also for SeaMonkey only: bug 19260).
Whiteboard: DUPEME?

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME?
Duplicate of bug: 306625
You need to log in before you can comment on or make changes to this bug.