sdk/console/plain-text leaks

RESOLVED FIXED

Status

Add-on SDK
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: erikvold, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Created attachment 773767 [details]
screen shot

I made an add-on with a blank main.js and it appears that the sdk/console/plain-text module is leaking.  See the attached screen shot, it was taken after forcing a gc multiple times.
Created attachment 773779 [details]
Pointer to Github pull request: https://github.com/mozilla/addon-sdk/pull/1094

Pointer to Github pull-request
Attachment #773779 - Flags: review?(rFobic)
Duplicate of this bug: 892849
Comment on attachment 773779 [details]
Pointer to Github pull request: https://github.com/mozilla/addon-sdk/pull/1094

Thanks!
Attachment #773779 - Flags: review?(rFobic) → review+

Comment 4

5 years ago
Commits pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/3aa505d198fb7ffef0abdec23863583ec48e5d09
Bug 892341 sdk/console/plain-text leaks, use a weak ref instead of a strong ref

https://github.com/mozilla/addon-sdk/commit/1cc54b179442abb4e575b03d1909ee3d36bfa84d
Merge pull request #1094 from erikvold/892341

Bug 892341 sdk/console/plain-text leaks, use a weak ref instead of a strong ref r=@gozala
This should be uplifted imo, because every 1.14 jetpack in existence is leaking due to the leak patched here.
(In reply to Erik Vold [:erikvold] [:ztatic] from comment #5)
> This should be uplifted imo, because every 1.14 jetpack in existence is
> leaking due to the leak patched here.

What kind of a leak are we talking about here. Does it only leak if the add-on is disabled at runtime? Does the leak grow in size over time?
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Depends on: 897683
You need to log in before you can comment on or make changes to this bug.